Project

General

Profile

Feature #1594

Split of BSC part from CoreNITB part

Added by laforge over 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/23/2016
Due date:
% Done:

40%

Estimated time:
Spec Reference:

Description

Right now we have a stand-alone OsmoBSC with Abis and A interface, but we don't have a stand-alone core network without the BSC part.

If the A-interface-split is properly done throughout the code, we can do away with the NITB-internal BSC and can have our NITB talk to other BSCs

This also enables us to properly attache the partial Osmo-GANC implementation, offering a UMA/GAN interface to the NITB.


Related issues

Related to OsmoNITB - Feature #1595: Addition of an Iu-CS interfaceClosed2016-05-14

Is duplicate of OpenBSC - Feature #1845: Full BSC/MSC split in NITB/MSCClosed2016-11-18

History

#1 Updated by laforge over 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30

#2 Updated by neels about 2 years ago

Splitting MSC from BSC is quite intricate, a consequence is the destruction of osmo-nitb as it exists today.

A split is complete on the sysmocom/iu branch, although that branch merely drops dead all BSC related code and
replaces it with IuCS.

An MSC/BSC split will only be mergeable to master when a proper A interface has been implemented.
Work is ongoing, but it is hard to express this in a percentage, so leaving at 30% for now.

#3 Updated by neels about 2 years ago

#4 Updated by neels about 2 years ago

To clarify, we will most probably first have a standalone MSC for 3G operation
(osmo-cscn, #1595) and an A-interface will follow later, which will replace
osmo-nitb with a 2G and 3G capable osmo-cscn entirely.

#5 Updated by laforge almost 2 years ago

  • Priority changed from Normal to Urgent

#6 Updated by laforge almost 2 years ago

  • Priority changed from Urgent to Normal

#7 Updated by neels almost 2 years ago

neels wrote:

An MSC/BSC split will only be mergeable to master when a proper A interface has been implemented.
Work is ongoing, but it is hard to express this in a percentage, so leaving at 30% for now.

Correction: some commits that split MSC/BSC are already waiting to be submitted for review.
They introduce libxsc and separate the linking scopes without breaking osmo-nitb.
They will be submitted in the upcoming week(s) in the course of the IuCS patches.

Still, a split of osmo-nitb into osmo-cscn and osmo-bsc will only be merged to master when
a proper A interface is in place.

#8 Updated by neels almost 2 years ago

#9 Updated by neels over 1 year ago

Some mscsplit patches are waiting in gerrit, possibly the 'libxsc' needs a different name though, IIUC
https://gerrit.osmocom.org/1123

#10 Updated by neels over 1 year ago

The mscsplit commits waiting on gerrit have been modified to rename libxsc to libcommon-cs.

#11 Updated by neels over 1 year ago

mscsplit commits are still waiting, now waiting specifically for a reply to comment on https://gerrit.osmocom.org/1129

Will merge the first couple of mscsplit commits soon (once the jenkins checks for the rebased patches are through).

#12 Updated by neels over 1 year ago

the first part of the mscsplit branch is merged (actually the sysmocom/iu branch); as soon as patches https://gerrit.osmocom.org/1129 thru 1131 pass reviews, the remaining mscsplit commits will go through as well.

Next up in the mscsplit would be proper separation of gsm_network and gsm_subscriber_connection structs.

#13 Updated by neels over 1 year ago

The commits currently have a build failure because some USSD generation code was moved to libosmocore, and hence the patches will build only when https://gerrit.osmocom.org/1339 and https://gerrit.osmocom.org/1340 are merged.

#14 Updated by neels over 1 year ago

  • % Done changed from 30 to 40

The mentioned series of mscsplit commits was merged to openbsc master.

Next up would be a separation of the gsm_network and gsm_subscriber_connection structs
into libbsc and libmsc parts.

After a brief discussion on the openbsc@ ML, the naming shall be
gsm_network --> bsc_ctx / msc_ctx
and
gsm_subscriber_connection --> bsc_subscr_conn / msc_subscr_conn

(Date: Fri, 11 Nov 2016 18:22:33 +0100, Subject: Re: naming contest: gsm_network, gsm_subscriber_connection)

#15 Updated by neels over 1 year ago

On the vlr branch and in the queue for merge-to-master is a split of
the gsm_subscriber (note, not _connection) into struct bsc_sub and struct gprs_sub,
with complete replacement of the remaining gsm_subscriber with vlr_subscriber.

https://gerrit.osmocom.org/1682 (bsc_sub)
https://gerrit.osmocom.org/1684 (gprs_sub)

#16 Updated by neels over 1 year ago

above patches reviewed and tested with real equipment,
now named bsc_subscr and gprs_subscr.

#17 Updated by neels over 1 year ago

gprs_subscr patch is now merged to master, bsc_subscr patch still in discussion

#18 Updated by neels over 1 year ago

  • Is duplicate of Feature #1845: Full BSC/MSC split in NITB/MSC added

#19 Updated by neels over 1 year ago

  • Status changed from In Progress to Rejected

while the points here remain valid, we're now tracking this in #1845 instead.

#20 Updated by neels about 1 year ago

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)