Project

General

Profile

Feature #1748

create feed of nightly builds of osmo-bts/osmo-pcu for sysmoBTS 1002 + 2050

Added by laforge over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
osmo-bts-sysmo
Target version:
-
Start date:
06/12/2016
Due date:
% Done:

90%

Spec Reference:

Description

Similar to the nightly Debian dpkg builds of libosmo*, OsmoNITB, OsmoSGSN* for x86/x86_64, we should
have a nightly opkg package feed of libosmo*, osmo-bts and osmo-pcu for the sysmoBTS 1002 and 2050.

This would make it easy for any users of such hardware to test current git master on their devices, without going through manual SDK builds.

History

#1 Updated by laforge over 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

starting to experiment with SRCREV="${AUTOREV} for libosmo* and osmo-bts/osmo-pcu on local builds

#2 Updated by laforge over 2 years ago

  • Checklist item create build job to build the laforge/nightly branches added
  • Checklist item create new FEED_URI for the nightly builds added
  • Checklist item upload packages from build host to FEED_URI added
  • Checklist item basic testing of current nightly build added
  • Checklist item ensure we build and upload both sysmobts-v2 and sysmobts-2050 added
  • Checklist item update user manual with information about how to use nightly builds added
  • Checklist item check after some days if 'opkg upgrade' will actually update code as intended added
  • % Done changed from 10 to 30

build has completed with current master of libosmo*, openbsc, osmo-bts and osmo-pcu. Related changes have been committed to meta-sysmocom-bsp and meta-telephony into the 'laforge/nightly' branch.

What's missing? See checklist.

#3 Updated by laforge over 2 years ago

  • Checklist item create build job to build the laforge/nightly branches set to Done
  • Checklist item create new FEED_URI for the nightly builds set to Done
  • Checklist item upload packages from build host to FEED_URI set to Done

#4 Updated by laforge over 2 years ago

  • % Done changed from 30 to 70

#5 Updated by laforge over 2 years ago

build was executed at 1am UTC last night, and it only re-built the osmo* repositories from git, as well as the filesystem image. So everything looks fine from that point of view.

#6 Updated by laforge over 2 years ago

  • Checklist item basic testing of current nightly build set to Done
  • Checklist item update user manual with information about how to use nightly builds set to Done

#7 Updated by laforge over 2 years ago

  • Checklist item deleted (ensure we build and upload both sysmobts-v2 and sysmobts-2050)
  • Assignee changed from laforge to dlsitzer
  • % Done changed from 70 to 90

we don't actually do a separate sysmobts-2050 build anymore, we simply use the sysmobts-v2 builds on the 2050 these days. there are some manual steps that need to be executed after flashing, which we need to automatize.

Assigning to dlsitzer to test if opkg upgrade works on the nightly builds.

#8 Updated by lazlo over 2 years ago

I tested the 201310-testing firmware and the status is as follows

  • image boots
  • seen location updates form subscribers I've set up
  • sent MO and MT SMS successfully
  • made voice calls with FR codec - worked
  • PCU (in combination with SGSN+GGSN) seems to have an issue (likely to be #1756) that made it not possible to have GPRS traffic. the problem was only identified by comparing the setup with the same system with 201310 firmware with the same config (where GPRS traffic was possible)

#9 Updated by laforge about 2 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)