Project

General

Profile

Bug #1772

User reports/suspects RTP statistics in MGCP reports are broken

Added by laforge about 2 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
OpenBSC
Target version:
-
Start date:
07/11/2016
Due date:
% Done:

20%

Estimated time:
Resolution:
Spec Reference:

Description

A user reports that the RTP statistics (number of lost packets, ...) reported at the end of the conversation are broken. They were looking at the MGCP reports, so it could still be that RTCP is correct but MGCP wrong.

Let's try to test this manually and think of how we can create a test case about this kind of behavior.

History

#1 Updated by laforge about 2 years ago

  • Assignee set to daniel

#2 Updated by laforge over 1 year ago

  • Assignee changed from daniel to dexter

#3 Updated by dexter about 1 year ago

More context on this would be very helpful. How do I get the statistics/reports displayed?

#4 Updated by dexter about 1 year ago

  • Status changed from New to Feedback

#5 Updated by laforge about 1 year ago

  • Status changed from Feedback to New

I'm sure it's easy to figure out when and how any RTP related statistics are displayed in MGCP. a quick grep for 'stats' in openbsc/src/libmgcp is sufficient to turn up "mgcp_format_stats()" and related code.

#6 Updated by laforge about 1 year ago

  • Priority changed from Normal to High

#7 Updated by dexter about 1 year ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

I have done some tests where I intentionally drop RTP frames regualry. The number of intentionally dropped frames matches the number in the statistics. Some more information about the error behavior and the affected values would be very helpful.

#8 Updated by laforge about 1 year ago

  • Status changed from In Progress to Rejected

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)