Project

General

Profile

Bug #2258

jenkins.osmocom.org's build slave link to the osmo-gsm-tester-rnd setup fails "half" of the time

Added by neels 7 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
sysmocom
Target version:
-
Start date:
05/15/2017
Due date:
% Done:

0%

Spec Reference:

Description

It seems that the link between jenkins.osmocom.org and the sysmocom office is unreliable.
Test runs abort halfway through with some java exceptions coming from the build slave connection.
e.g. http://jenkins.osmocom.org/jenkins/view/osmo-gsm-tester/job/osmo-gsm-tester_run/47/console

More or less half of the test runs fail because of this.


Related issues

Related to Osmocom.org Servers - Feature #2502: reproducible / automatic build slave generation New 09/07/2017

History

#1 Updated by neels 7 months ago

  • Subject changed from jenkins.osmocom.org's build slave on the osmo-gsm-tester fails "half" of the time to jenkins.osmocom.org's build slave link to the osmo-gsm-tester-rnd setup fails "half" of the time

#2 Updated by neels 7 months ago

(this is discussed on the sysmocom internal issue #3601)

#3 Updated by pespin 7 months ago

It seems the connection is more robust after VPN changes done lately. @Neels I think you use jenkins to run tests more than I do, can we mark the issue as resolved?

#4 Updated by neels 7 months ago

  • Status changed from New to Resolved

An OpenVPN downgrade has made the link highly stable.

#5 Updated by laforge 4 months ago

  • Status changed from Resolved to Closed

#6 Updated by laforge 3 months ago

  • Related to Feature #2502: reproducible / automatic build slave generation added

Also available in: Atom PDF