Project

General

Profile

Bug #2491

osmo-bsc does not allow configuring 'cs7 instance 0' / 'asp' / 'remote-ip'

Added by neels 14 days ago. Updated 5 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
09/05/2017
Due date:
% Done:

0%

Spec Reference:

Description

with current osmo-bsc.git osmo-bsc, VTY config like this:

cs7 instance 0
 point-code 0.42.1
 asp asp-clnt-OsmoBSC 2905 0 m3ua
  remote-ip 10.23.24.1  ! where to reach the STP

results in

<002d> ../../../src/libosmo-sccp/src/osmo_ss7.c:1229 0: ASP Restart for server not implemented yet!
There is no such command.
Error occurred during reading below line:
  remote-ip 10.23.24.1  ! where to reach the STP

<0005> ../../../../src/osmo-bsc/src/libbsc/bsc_init.c:539 Failed to parse the config file: 'osmo-bsc/doc/examples/osmo-bsc/osmo-bsc_custom-scpp.cfg'
Bootstrapping the network failed. exiting.
full talloc report on 'sccp' (total      1 bytes in   1 blocks)

It works in osmo-msc, osmo-bsc should probably be adjusted to work similarly.

History

#1 Updated by dexter 5 days ago

  • Status changed from New to Feedback
  • Assignee changed from dexter to neels

To me this looks like a VTY parser problem. I can reproduce the error, but when I remove the comment "! where to reach the STP" it gets parsed. Please try it out on your side.

#2 Updated by neels 5 days ago

  • Status changed from Feedback to Resolved

indeed, I wasn't aware of the comments having to be on their own line.
https://gerrit.osmocom.org/#/c/3882/
I added this patch and then forgot about this issue

Also available in: Atom PDF