Project

General

Profile

Bug #2645

libosmocodec fails to pass "make test" on some CPUs

Added by laforge 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
libosmocodec
Target version:
-
Start date:
11/16/2017
Due date:
% Done:

0%

Estimated time:
Spec Reference:

Description

At least in OBS, we every so often get a build ("make check") failure on some build nodes. We have to figure out what kind of specific CPU they use to understand why our code fails.

So far, the output simply looks like this:

Visit
https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/libosmocore/Debian_8.0/x86_64

Package network:osmocom:nightly/libosmocore failed to build in Debian_8.0/x86_64

Check out the package for editing:
  osc checkout network:osmocom:nightly libosmocore

Last lines of build log:
[  238s] -tch_hr_decode: n_errors=10 n_bits_total=456 ber=0.02
[  238s] -tch_hr_decode: n_errors=10 n_bits_total=456 ber=0.02
[  238s] -pdtch_decode: n_errors=0 n_bits_total=456 ber=0.00
[  238s] -pdtch_decode: n_errors=132 n_bits_total=588 ber=0.22
[  238s] -pdtch_decode: n_errors=220 n_bits_total=676 ber=0.33
[  238s] -pdtch_decode: n_errors=0 n_bits_total=444 ber=0.00
[  238s] -pdtch_decode: n_errors=0 n_bits_total=456 ber=0.00
[  238s] -pdtch_decode: n_errors=132 n_bits_total=588 ber=0.22
[  238s] -pdtch_decode: n_errors=220 n_bits_total=676 ber=0.33
[  238s] -pdtch_decode: n_errors=0 n_bits_total=444 ber=0.00
[  238s] -Success
[  238s] ./testsuite.at:69: exit code was 132, expected 0
[  238s] 11. testsuite.at:66: 11. coding (testsuite.at:66): FAILED (testsuite.at:69)
[  238s] debian/rules:26: recipe for target 'override_dh_auto_test' failed
[  238s] make[1]: *** [override_dh_auto_test] Error 1
[  238s] make[1]: Leaving directory '/usr/src/packages/BUILD'
[  238s] debian/rules:15: recipe for target 'build' failed
[  238s] make: *** [build] Error 2
[  238s] dpkg-buildpackage: error: debian/rules build gave error exit status 2
[  238s]
[  238s] build33 failed "build libosmocore_0.10.2.20171104.dsc" at Sat Nov  4 19:55:17 UTC 2017.
[  238s]
[  238s] ### VM INTERACTION START ###
[  239s] Powering off.
[  239s] [  228.526201] reboot: Power down
[  241s] ### VM INTERACTION END ###
[  241s]
[  241s] build33 failed "build libosmocore_0.10.2.20171104.dsc" at Sat Nov  4 19:55:21 UTC 2017.
[  241s]

I've now created https://build.opensuse.org/package/show/home:laforge/libosmocore which is a copy of libosmocore which does a "cat /proc/cpuinfo" before executing the autotest suite.


Related issues

Is duplicate of libosmocore - Bug #2386: libosmocoding build failure on OBSClosed2017-07-21

History

#1 Updated by laforge 8 months ago

So far, the problem could be observed on build33, build35, build36, build31, build32

#2 Updated by laforge 8 months ago

  • Is duplicate of Bug #2386: libosmocoding build failure on OBS added

#3 Updated by laforge 8 months ago

  • Status changed from New to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)