Project

General

Profile

Bug #2649

MGCP connection idetnifiers are hex strings, not integers

Added by laforge 8 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
11/17/2017
Due date:
% Done:

100%

Estimated time:

Description

The MGCP spec in RFC3435 is quite clear: Connection Identifiers are
hexadecimal strings of up to 32 characters. We should not print
and parse them as integers on either client or server.

History

#1 Updated by laforge 8 months ago

  • Status changed from New to In Progress

#2 Updated by laforge 8 months ago

  • Status changed from In Progress to New
  • Assignee changed from laforge to dexter
  • % Done changed from 0 to 20

See https://gerrit.osmocom.org/4906 as a starting point

#3 Updated by dexter 8 months ago

  • Status changed from New to In Progress

#4 Updated by dexter 8 months ago

  • % Done changed from 20 to 100

The problem is now fixed, we are using 32 digit uppercase hex strings now.

#5 Updated by dexter 8 months ago

  • Status changed from In Progress to Resolved

#6 Updated by laforge 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)