Project

General

Profile

Bug #2671

OsmoBTS + asterisk

Added by bardonov 2 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/21/2017
Due date:
% Done:

0%

Spec Reference:

Description

good day colleagues,
I have found a bug, when tested openbts + asterisk
when OBTS send invite to asterisk (I use asterisk on outside server), i have localhost ip in section body option message invite
its dump
@
<--- SIP read from UDP:10.135.12.4:5069 --->
INVITE sip::5060 SIP/2.0
Via: SIP/2.0/UDP 10.135.12.4:5069;rport;branch=z9hG4bKDF1N7Zt4vecjN
Max-Forwards: 70
From: <sip::5069>;tag=8DFF394y7pmjH
To: <sip::5060>
Call-ID: 5c402941-493c-1236-e1af-3860773e9612
CSeq: 930060148 INVITE
Contact: <sip:10.135.12.4:5069>
User-Agent: sofia-sip/1.12.11devel
Allow: INVITE, ACK, BYE, CANCEL, OPTIONS, PRACK, MESSAGE, SUBSCRIBE, NOTIFY, REFER, UPDATE
Supported: timer, 100rel
Content-Type: application/sdp
Content-Length: 124

v=0
o=Osmocom 0 0 IN IP4 127.0.0.1
s=GSM Call
c=IN IP4 127.0.0.1

t=0 0
m=audio 40998 RTP/AVP 98
a=rtpmap:98 AMR/8000
<------------->
--- (13 headers 7 lines) ---
Sending to 10.135.12.4:5069 (no NAT)
Sending to 10.135.12.4:5069 (no NAT)
Using INVITE request as basis request - 5c402941-493c-1236-e1af-3860773e9612
Found peer 'GSM' for '102' from 10.135.12.4:5069 == Using SIP RTP CoS mark 5
Found RTP audio format 98
Found audio description format AMR for ID 98
Capabilities: us - (gsm|g722|amr), peer - audio=(amr)/video=(nothing)/text=(nothing), combined - (amr)
Non-codec capabilities (dtmf): us - 0x1 (telephone-event|), peer - 0x0 (nothing), combined - 0x0 (nothing)
Peer audio RTP is at port 127.0.0.1:40998
Looking for 111 in gsmsubscriber (domain 10.135.12.38)
sip_route_dump: route/path hop: <sip:10.135.12.4:5069>
@
and sent RTP packet to 127.0.0.1:40998

History

#1 Updated by bardonov 2 months ago

sorry I was wrong,of course it's OsmoBTS

#2 Updated by laforge 2 months ago

  • Subject changed from OpenBTS + asterisk to OsmoBTS + asterisk

#3 Updated by laforge 2 months ago

  • Assignee set to dexter

Can you please provide a full description of your setup? Are you using osmo-bsc+osmo-msc or omso-nitb? Which exact versions of which of the components are you using? We can only help you if you provide us sufficient context. Thanks!

#4 Updated by bardonov 2 months ago

i'm using 2 macnine
1-server:
OsmoBSC (0.15.0.763-5121) + OsmoBTS (0.4.0.433-8913) + Osmo-Sip-Connector (last version)
this config sip-connector:

app
mncc
socket-path /tmp/bsc_mncc
sip
local 10.135.12.4 5069
remote 10.135.12.38 5060

2-server:
Asterisk 13.18.2 + Patch github.com/traud/asterisk-amr

as the result, I found RTP is sent to localhost (debug rtp on asterisk), I solved the problem when installed asterisk on 1 server

Also available in: Atom PDF