Project

General

Profile

Bug #2686

Create PDP Context has duplicate GSN Address TLV

Added by lynxis 8 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/28/2017
Due date:
% Done:

100%

Estimated time:
Spec Reference:

create_pdp_wrong.pcapng create_pdp_wrong.pcapng 428 Bytes lynxis, 11/28/2017 02:32 PM

History

#1 Updated by lynxis 8 months ago

  • Subject changed from Create PDP Context has duplicate GGSN Address TLV to Create PDP Context has duplicate GSN Address TLV

#2 Updated by lynxis 8 months ago

osmo-sgsn nightly

ii osmo-sgsn 1.2.0.2017112 amd64 OsmoSGSN: Osmocom's Serving GPRS Suppor

#3 Updated by laforge 7 months ago

  • Assignee set to laforge

#4 Updated by laforge 7 months ago

  • Status changed from New to Rejected
  • % Done changed from 0 to 100

This is not a bug, but actually how GTP works. See Table 5 of Section 7.3.1 of 3GPP TS 29.060: There are two subsequent GSN address fieddls: The first one for signaling (GTP-C) and the second one for the user plane (GTP-U). The rationale here is that you can have one control plane instance but many user plane instances to do load balancing.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)