Project

General

Profile

Bug #3088

ttcn3/titan build slaves not yet generated by ansible

Added by laforge about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
03/19/2018
Due date:
% Done:

90%

Spec Reference:

Description

Whether or not the TTCN-3 jobs are generated by JJB (not yet), it's important that we can finally generate all our build slaves from ansible.

Please complete this ASAP so we can create new build slaves and remove old ones.

AFAIK this is the latest remaining item?


Related issues

Related to Osmocom.org Servers - Feature #2502: reproducible / automatic build slave generationResolved09/07/2017

History

#1 Updated by laforge about 1 year ago

  • Related to Feature #2502: reproducible / automatic build slave generation added

#2 Updated by lynxis about 1 year ago

  • % Done changed from 0 to 70

in theory it should work.

However the nplab-m3ua-test and nplab-sua-test are missing a containter from the registry: "laforge/sigtran-tests"

and the ggsn tests are failing with "(Transport endpoint is not connected)"

#3 Updated by lynxis about 1 year ago

  • Status changed from New to In Progress

#4 Updated by lynxis about 1 year ago

The ggsn couldn't start because of the missing tun permission

#5 Updated by pespin about 1 year ago

We noticed today that the deb9build-ansible container doesn't have ttcn3 dependencies installed by ansible.

We need to install the "eclipse-titan" package from osmocom latest OBS repos, since the one in debian is too old/broken for our needs.

I installed it manually, but we need to add it to ansible. These are the steps I did manually:

wget http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/Release.key
apt-key add Release.key
rm Release.key
echo "deb http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/ ./" > /etc/apt/sources.list.d/osmocom-latest.list
apt-get update
apt-get install eclipse-titan

#6 Updated by lynxis about 1 year ago

I thought this would be all in the docker container.

#7 Updated by lynxis about 1 year ago

i've installed titan on the 3 debian9 host ansible slaves.

#8 Updated by lynxis about 1 year ago

  • % Done changed from 70 to 90

waiting for the last patches to be merged.

#10 Updated by lynxis about 1 year ago

  • Status changed from In Progress to Stalled

#11 Updated by lynxis about 1 year ago

  • Status changed from Stalled to Resolved

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)