Project

General

Profile

Bug #4026

osmo-hlr on Ubuntu 19.04: Value too large for defined data type

Added by laforge about 2 months ago. Updated 25 days ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
05/26/2019
Due date:
% Done:

100%


Description

Visit
https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/osmo-hlr/xUbuntu_19.04/x86_64

Package network:osmocom:nightly/osmo-hlr failed to build in xUbuntu_19.04/x86_64

Check out the package for editing:
osc checkout network:osmocom:nightly osmo-hlr

Last lines of build log:
[  156s]
[  156s]  db_subscr_get_by_imsi(dbc, imsi0, &g_subscr) --> 0
[  156s] +DAUC Cannot convert LU timestamp '2019-05-26 03:05:03' to time_t: Value too large for defined
data type
[  156s]  struct hlr_subscriber {
[  156s]    .id = 1,
[  156s]    .imsi = '123456789000000',
[  156s] @@ -719,6 +742,7 @@
[  156s]  --- Delete subscribers
[  156s]
[  156s]  db_subscr_get_by_imsi(dbc, imsi0, &g_subscr) --> 0
[  156s] +DAUC Cannot convert LU timestamp '2019-05-26 03:05:03' to time_t: Value too large for defined
data type
[  156s]  struct hlr_subscriber {
[  156s]    .id = 1,
[  156s]    .imsi = '123456789000000',
[  156s] 5. testsuite.at:32: 5. db (testsuite.at:32): FAILED (testsuite.at:37)
[  156s] make[1]: *** [debian/rules:17: override_dh_auto_test] Error 1
[  156s] make[1]: Leaving directory '/usr/src/packages/BUILD'
[  156s] make: *** [debian/rules:7: build] Error 2
[  156s] dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
[  156s]
[  156s] morla3 failed "build osmo-hlr_1.0.0.32.29f3.dsc" at Sun May 26 03:05:03 UTC 2019.
[  156s]
[  156s] ### VM INTERACTION START ###
[  159s] [  143.935521] sysrq: SysRq : Power Off
[  159s] [  143.956602] reboot: Power down
[  159s] ### VM INTERACTION END ###
[  159s]
[  159s] morla3 failed "build osmo-hlr_1.0.0.32.29f3.dsc" at Sun May 26 03:05:07 UTC 2019.
[  159s]

History

#1 Updated by osmith about 2 months ago

  • Status changed from New to In Progress
  • Assignee changed from sysmocom to osmith

#2 Updated by osmith about 2 months ago

  • % Done changed from 0 to 90

This seems to be a regression in glibc, also reported in the fedora tracker:
https://bugzilla.redhat.com/show_bug.cgi?id=1653340

Interestingly, the regression test program from the fedora tracker always reproduces the problem. But our test case is only failing 2 out of 3 times or so (tested in a ubuntu 19.04 docker image).

There was no upstream bug report yet, so I reported it upstream too:
https://sourceware.org/bugzilla/show_bug.cgi?id=24630

It seems that we need to wait until it is fixed upstream, and the fix lands in ubuntu 19.04. In the meantime, we can use this workaround to have the packages building for ubuntu 19.04 again:
https://gerrit.osmocom.org/c/osmo-hlr/+/14351

#3 Updated by osmith about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Workaround is merged.

#4 Updated by osmith about 2 months ago

  • Subject changed from osmo-hlr on Ubuntu 19.10: Value too large for defined data type to osmo-hlr on Ubuntu 19.04: Value too large for defined data type

#5 Updated by osmith about 2 months ago

  • Status changed from Resolved to In Progress
  • % Done changed from 100 to 90

Turns out, that this was not a regression in glibc. Proper fix submitted:
https://gerrit.osmocom.org/c/osmo-hlr/+/14364

#6 Updated by osmith 25 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)