Project

General

Profile

Feature #1525

Use the Radio Access Capabilites that are being transferred via BSSGP (downlink)

Added by zecke over 4 years ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/22/2016
Due date:
% Done:

100%

Spec Reference:

Description

Parsing these RA Cap is prepared but not enabled, since the osmo SGSN sends bogus values. This should be fixed and the use of those RA Cap values should be enabled.

Note that the current analyse functions which extract the (EGPRS) MS class do not match the access type technologies field, which must be fixed. This is also relevant for the extraction of the 8PSK power class (see #2457)


Related issues

Related to OsmoPCU - Bug #3499: pcu is logging "Allocating DL TBF: MS_CLASS=0/0" ; TLV parsing code commented?Resolved08/24/2018

History

#1 Updated by zecke over 4 years ago

  • Tracker changed from Bug to Feature

#2 Updated by laforge over 2 years ago

  • Assignee changed from msuraev to stsp

#3 Updated by msuraev almost 2 years ago

  • Related to Bug #3499: pcu is logging "Allocating DL TBF: MS_CLASS=0/0" ; TLV parsing code commented? added

#4 Updated by laforge over 1 year ago

  • Assignee changed from stsp to lynxis

#5 Updated by laforge 10 months ago

  • Assignee changed from lynxis to sysmocom
  • Priority changed from Low to Normal

#6 Updated by pespin 9 months ago

This ticket is a duplicate (talking about same issue) of #3499

We need to add some TTCN3 test to check emulation-SGSN sending this data to PCU and make sure it's taken into account.

Related code: gprs_bssgp_pcu_rx_dl_ud() (src/gprs_bssgp_pcu.cpp).

Related commits (from older to newer, they are together in history):
0df80be95e3604656ff36024f793ef3c36455051
4a07a3be11e7366b557bab795aa23b42725ec23e
f4bb42459ca4f3e18f9ee3d3a27389b85c7692e8
741d25cb6f8c0c1522cf6d1be2fea49356ecd4bd

#7 Updated by pespin 9 months ago

  • Assignee changed from sysmocom to pespin

#8 Updated by pespin 8 months ago

Thanks to all recent work done in osmo-pcu CSN1/RLCMAC decoder, I could investigate the issue further, and it should be fixed by https://gerrit.osmocom.org/c/osmo-pcu/+/17524

Tested with: https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/17526

keith give it a try if you want.

PS: I also submitted a patch to wirershark to be able to decode non CS-1 (e)gprs data blocks, see #1542.

Closing this ticket and keeping #3499 (duplicate of this ticket) open until they are merged.

#9 Updated by pespin 8 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)