Project

General

Profile

Actions

Bug #1617

closed

osmo-bts-trx doesn't support CBCH

Added by laforge almost 6 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
osmo-bts-trx
Target version:
Start date:
02/23/2016
Due date:
% Done:

100%

Spec Reference:
Tags:

Description

While the common part of osmo-bts (and osmo-bts-sysmo, and OpenBSC) support CBCH, osmo-bts-trx doesn't.


Checklist

  • TTCN3 tests (null and non-null blocks
  • re-test other BTS like sysmoBTS to avoid regression
  • test osmo-bts-trx CBCH with real phone
  • update documentation (no CBCH constraint on TRX anymore)

Related issues

Related to OsmoBSC - Bug #3532: CBCH presence no longer advertised in SI4 since timeslot FSM was mergedResolvedlaforge09/09/2018

Actions
Related to OsmoBTS - Bug #3533: OsmoBTS rejects RSL SMSCB COMMANDResolvedlaforge09/09/2018

Actions
Related to OsmoBTS - Bug #3534: CBCH messages not visible in GSMTAPResolvedlaforge09/09/2018

Actions
Related to OsmocomBB - Feature #3558: trxcon/scheduler: implement CBCH supportResolvedfixeria09/16/2018

Actions
Actions #1

Updated by laforge about 5 years ago

  • Target version set to osmo-bts-trx refresh
Actions #2

Updated by laforge over 4 years ago

Actions #3

Updated by laforge almost 4 years ago

Actions #4

Updated by laforge over 3 years ago

  • Assignee set to sysmocom
  • Priority changed from Normal to High
Actions #5

Updated by laforge over 3 years ago

  • Assignee changed from sysmocom to laforge
  • % Done changed from 0 to 20

initial patches developed today, pending re-testing of existing BTS models as well as testing of osmo-bts-trx

Actions #6

Updated by laforge over 3 years ago

  • Checklist item TTCN3 tests (null and non-null blocks added
  • Checklist item re-test other BTS like sysmoBTS to avoid regression added
  • Checklist item test osmo-bts-trx CBCH with real phone added
  • Checklist item look into osmo-bts-virtual added
Actions #7

Updated by laforge over 3 years ago

  • Checklist item update documentation (no CBCH constraint on TRX anymore) added
Actions #8

Updated by laforge over 3 years ago

  • Status changed from New to In Progress
Actions #9

Updated by laforge over 3 years ago

  • Related to Bug #3532: CBCH presence no longer advertised in SI4 since timeslot FSM was merged added
Actions #10

Updated by laforge over 3 years ago

  • Related to Bug #3533: OsmoBTS rejects RSL SMSCB COMMAND added
Actions #11

Updated by laforge over 3 years ago

  • Related to Bug #3534: CBCH messages not visible in GSMTAP added
Actions #12

Updated by laforge over 3 years ago

  • % Done changed from 20 to 40

patch has been merged, test cases still TBD at the moment

Actions #13

Updated by laforge over 3 years ago

Updated Cell_Broadcast with usage information (usage was the same even befor osmo-bts-trx support, just wasn't documented there at all)

Actions #14

Updated by laforge over 3 years ago

  • Tags set to SMSCB, TTCN3
Actions #15

Updated by laforge over 3 years ago

  • Checklist item re-test other BTS like sysmoBTS to avoid regression set to Done
Actions #16

Updated by fixeria over 3 years ago

  • Related to Feature #3558: trxcon/scheduler: implement CBCH support added
Actions #17

Updated by laforge over 3 years ago

  • Checklist item test osmo-bts-trx CBCH with real phone set to Done
Actions #18

Updated by laforge over 3 years ago

  • % Done changed from 40 to 70

with patch https://gerrit.osmocom.org/#/c/osmo-bts/+/11005 applied, I can deliver SMSCB to a Galaxy S5 phone.

Actions #19

Updated by laforge about 3 years ago

  • Status changed from In Progress to Stalled
Actions #20

Updated by laforge over 2 years ago

Actions #21

Updated by laforge over 2 years ago

  • Checklist item TTCN3 tests (null and non-null blocks set to Done
Actions #22

Updated by laforge over 2 years ago

  • Checklist item deleted (look into osmo-bts-virtual)
  • Checklist item update documentation (no CBCH constraint on TRX anymore) set to Done
  • Status changed from Stalled to Resolved
  • % Done changed from 70 to 100

CBCH implemented fully in osmo-bts-trx; TTCN3 test suite passing for CBCH on SDCCH4. SDCCH8 doesn't pass, but that's more a trxcon/l1ctl problem.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)