Project

General

Profile

Bug #1793

EGPRS PCU: wrong encoding of EGPRS PUAN message

Added by arvind.sirsikar almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Target version:
-
Start date:
08/09/2016
Due date:
% Done:

0%

Spec Reference:

Description

Hi All,

static void write_packet_ack_nack_desc_egprs function is written incomplete causing wrong encoding of PUAN. currently this function is written assuming there is no gap between VR and VQ.

urbb_len variable is always calculated to be 0( except some corner cases)causing incomplete information in PUAN. The issue is severe when tested with bad radio condition causing MS stalled in UL and there by call instability.

Thanks,
Aravind Sirsikar

History

#1 Updated by arvind.sirsikar almost 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)