Project

General

Profile

Bug #1865

TCH/F_PDCH is not working as TCH/F channel for CS voice call in USRP B210 board ( osmo-trx)

Added by mrinal about 3 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
osmo-bts-trx
Target version:
-
Start date:
12/02/2016
Due date:
% Done:

0%

Spec Reference:

Description

In old commit version TCH/F_PDCH was working fine as TCH/F as well as PDCH channel .We further checked the commit version using git bisect to find out the exact version from where this functionality is broken . Below is the commit version of BSC :

c3f72f63afde926dfc46827d6880055597515fb6
dyn TS: fix: ts_subslots() for TCH/F_PDCH in PDCH mode

Below failure logs observed when CS call is initiated using TCH/F_PDCH channel:

0004> bsc_init.c:288 bootstrapping RSL for BTS/TRX (0/2) on ARFCN 563 using MCC=901 MNC=60 LAC=1 CID=0 BSIC=63
<0000> chan_alloc.c:355 Failed to allocate TCH_F channel
<0004> abis_rsl.c:1755 BTS 0 CHAN RQD: no resources for TCH_F 0xee
<0000> chan_alloc.c:355 Failed to allocate TCH_H channel
<0004> abis_rsl.c:1755 BTS 0 CHAN RQD: no resources for TCH_H 0x4d
<0000> chan_alloc.c:355 Failed to allocate TCH_H channel
<0004> abis_rsl.c:1755 BTS 0 CHAN RQD: no resources for TCH_H 0x6a

bsc_log_dyn_tch_not_working_c3f7_version.txt bsc_log_dyn_tch_not_working_c3f7_version.txt 23.6 KB mrinal, 12/02/2016 09:58 AM
bsc_log_dyn_tch_working_2afff_version.txt bsc_log_dyn_tch_working_2afff_version.txt 30.2 KB mrinal, 12/02/2016 09:59 AM
open-bsc.cfg-trx-dyn-edge-nano open-bsc.cfg-trx-dyn-edge-nano 3.9 KB msuraev, 05/31/2017 12:08 PM
osmo-bts.cfg-trx1 osmo-bts.cfg-trx1 1.03 KB msuraev, 05/31/2017 12:08 PM
osmo-pcu.cfg-edge osmo-pcu.cfg-edge 565 Bytes msuraev, 05/31/2017 12:08 PM
osmo-sgsn.cfg osmo-sgsn.cfg 1.51 KB msuraev, 05/31/2017 12:08 PM

Related issues

Related to OsmoMSC - Feature #1778: avoid mismatching TCH/F vs TCH/H pchan typesResolved07/21/2016

Blocks OsmoBTS - Bug #1853: validate dynamic TCH/PDCH support in osmo-bts-trxResolved11/18/2016

History

#1 Updated by laforge about 3 years ago

  • Category set to osmo-bts-trx

for the record, here a response from Neels on the mailing list:

please be aware that TCH/F_PDCH is a pchan type that is designed for use with
ip.access nanoBTS exclusively. This BTS model understands a non-standard RSL
message to de-/activate PDCH ("PDCH Act"). Some of our other BTS software also
support this pchan kind: sysmoBTS, lc15 and osmo-bts-trx if I remember
correctly, but preferably use the pchan type TCH/F_TCH/H_PDCH in your osmo-bsc
or osmo-nitb config.

When you refer to a PS call, do you mean that GPRS service is used to place a
VoIP call? This is the same as saying that GPRS is functional.

There should be no significant difference in functionality concerning dynamic
timeslots (either kind) between master and commit 7bc6986f6ba, all commits that
"really matter" concerning dyn TS were already present in that revision.

Please verify your statements and/or accompany with log output,
and also try TCH/F_TCH/H_PDCH instead.

If the problem persists, please a) bisect to pinpoint the failing revision and
b) add full log output, preferably with DRSL and DNM logs set to debug level.

I verified that TCH/F_TCH/H_PDCH is functional on sysmobts with all the newest
commits just yesterday.

So my questions are: does the fully dynamic (osmocom style) TCH/F_TCH/H_PDCH work? The TCH/F_PDCH is intended
primarily for nanoBTS support, not for osmo-bts.

#2 Updated by mrinal about 3 years ago

Yes TCH/F_TCH/H_PDCH works fine as TCH/H or as PDCH. But it does not work as TCH/F which means feature is not fully working.
Regarding TCH/F_PDCH even though it is not intended primarily for osmo-bts since the feature was working successfully earlier with osmo-bts and it was broken after the commit version I have mentioned in the issue description, I have raised this issue.

#3 Updated by laforge almost 3 years ago

#4 Updated by laforge almost 3 years ago

  • Assignee set to msuraev

#5 Updated by msuraev almost 3 years ago

  • Related to Bug #1853: validate dynamic TCH/PDCH support in osmo-bts-trx added

#6 Updated by msuraev over 2 years ago

  • Related to Feature #1778: avoid mismatching TCH/F vs TCH/H pchan types added

#7 Updated by msuraev over 2 years ago

  • Related to deleted (Bug #1853: validate dynamic TCH/PDCH support in osmo-bts-trx)

#8 Updated by msuraev over 2 years ago

  • Blocks Bug #1853: validate dynamic TCH/PDCH support in osmo-bts-trx added

#9 Updated by msuraev over 2 years ago

I'm unable to reproduce this locally with latest master using attached configs - the voice call goes through just fine. Could you please share you configs, command-line args etc.

#10 Updated by msuraev over 2 years ago

  • Assignee changed from msuraev to mrinal

#11 Updated by laforge about 2 years ago

  • Status changed from Feedback to Rejected

bug was unable to be reproduced and bug reporter did never respond to request for config files

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)