Project

General

Profile

Bug #1920

some nightly packages from build.opensuse.org missing

Added by neels almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Osmocom CNI Developers
Target version:
-
Start date:
01/17/2017
Due date:
% Done:

100%

Spec Reference:

Description

Some packages are too old, i.e. not being built every night.
For example, the openbsc package is from 12-Dec-2016 while the rest are from yesterday:

http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_8.0/

[   ] Packages                                 17-Jan-2017 12:05   78K   Details
[   ] Packages.gz                              17-Jan-2017 12:05   15K   Details
[   ] Release                                  17-Jan-2017 12:05  1.0K   Details
[   ] Release.gpg                              17-Jan-2017 12:05  481    Details
[   ] Release.key                              17-Jan-2017 12:05  1.1K   Details
[   ] Sources                                  17-Jan-2017 12:05   15K   Details
[   ] Sources.gz                               17-Jan-2017 12:05  3.8K   Details
[DIR] all/                                     16-Jan-2017 21:10    -   
[DIR] amd64/                                   16-Jan-2017 21:08    -   
[   ] cellmgr-ng_1.4.7.20170116.dsc            16-Jan-2017 21:00  1.1K   Details
[   ] cellmgr-ng_1.4.7.20170116.tar.xz         16-Jan-2017 21:00   93K   Details
[DIR] i386/                                    16-Jan-2017 21:10    -   
[   ] libosmo-abis_0.3.3.20170116.dsc          16-Jan-2017 20:59  1.1K   Details
[   ] libosmo-abis_0.3.3.20170116.tar.xz       16-Jan-2017 20:59   63K   Details
[   ] libosmo-netif_0.0.7.20170116.dsc         16-Jan-2017 21:06  1.0K   Details
[   ] libosmo-netif_0.0.7.20170116.tar.xz      16-Jan-2017 21:06  105K   Details
[   ] libosmo-sccp_0.7.1.20161221.dsc          21-Dec-2016 20:57  842    Details
[   ] libosmo-sccp_0.7.1.20161221.tar.xz       21-Dec-2016 20:57   44K   Details
[   ] libosmocore_0.9.6.20170116.dsc           16-Jan-2017 20:55  1.7K   Details
[   ] libosmocore_0.9.6.20170116.tar.xz        16-Jan-2017 20:55  442K   Details
[   ] libsmpp34_1.11.20170116.dsc              16-Jan-2017 20:54  1.0K   Details
[   ] libsmpp34_1.11.20170116.tar.xz           16-Jan-2017 20:54   33K   Details
[   ] openbsc_0.15.1.20161212.dsc              12-Dec-2016 22:29  1.8K   Details
[   ] openbsc_0.15.1.20161212.tar.xz           12-Dec-2016 22:29  619K   Details
[   ] openggsn_0.93.20170116.dsc               16-Jan-2017 20:58  1.0K   Details
[   ] openggsn_0.93.20170116.tar.xz            16-Jan-2017 20:58  101K   Details
[   ] osmo-pcap_0.0.9.20170116.dsc             16-Jan-2017 21:03  759    Details
[   ] osmo-pcap_0.0.9.20170116.tar.xz          16-Jan-2017 21:03   28K   Details
[   ] osmo-pcu_0.3.20170116.dsc                16-Jan-2017 21:01  828    Details
[   ] osmo-pcu_0.3.20170116.tar.xz             16-Jan-2017 21:01  217K   Details
[   ] osmo-sip-connector_1.20170116.dsc        16-Jan-2017 21:05  953    Details
[   ] osmo-sip-connector_1.20170116.tar.xz     16-Jan-2017 21:05   29K   Details

Related issues

Related to Cellular Network Infrastructure - Feature #1860: Include Ubuntu 16.04 LTS in nightly buildsClosed11/28/2016

History

#1 Updated by neels almost 3 years ago

The issue should be fixed by https://gerrit.osmocom.org/#/c/1612/
Keeping this ticket open until the fix has been verified (hopefully tomorrow).

Notifications for build failures have been put in place to be sent to openbsc@,
configuration is documented at
https://osmocom.org/projects/cellular-infrastructure/wiki/Nightly_Builds#E-Mail-Notifications-of-build-failures

#2 Updated by neels almost 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

#3 Updated by msuraev almost 3 years ago

Except osmo-stp which should be fixed by gerrit # 1616.

#4 Updated by msuraev almost 3 years ago

  • Related to Feature #1860: Include Ubuntu 16.04 LTS in nightly builds added

#5 Updated by zecke almost 3 years ago

On 17 Jan 2017, at 15:46, msuraev [REDMINE] <> wrote:

Issue #1920 has been updated by msuraev.

Except osmo-stp which should be fixed by gerrit # 1616.

osmo-stp. Looks like the libosmo*sccp.pc.in needs to mention talloc as
dependency as well/and or change the link order as well. :)

#6 Updated by neels almost 3 years ago

  • % Done changed from 50 to 90

It seems that now all packages are up-to-date and the fixes work;
except that I can't find osmo-stp there, maybe because it never existed?
The packages I was aiming at are fixed, keeping open for osmo-stp (which I'm not familiar with).

Index of /repositories/network:/osmocom:/nightly/Debian_8.0

Icon  Name                                     Last modified      Size  [DIR] Parent Directory                                              -   
[   ] Packages                                 17-Jan-2017 21:24   81K   Details
[   ] Packages.gz                              17-Jan-2017 21:24   16K   Details
[   ] Release                                  17-Jan-2017 21:24  1.0K   Details
[   ] Release.gpg                              17-Jan-2017 21:24  481    Details
[   ] Release.key                              17-Jan-2017 21:24  1.1K   Details
[   ] Sources                                  17-Jan-2017 21:24   15K   Details
[   ] Sources.gz                               17-Jan-2017 21:24  3.9K   Details
[DIR] all/                                     17-Jan-2017 21:24    -   
[DIR] amd64/                                   17-Jan-2017 21:24    -   
[   ] cellmgr-ng_1.4.7.20170117.dsc            17-Jan-2017 21:18  1.1K   Details
[   ] cellmgr-ng_1.4.7.20170117.tar.xz         17-Jan-2017 21:18   93K   Details
[DIR] i386/                                    17-Jan-2017 21:24    -   
[   ] libosmo-abis_0.3.3.20170117.dsc          17-Jan-2017 21:04  1.1K   Details
[   ] libosmo-abis_0.3.3.20170117.tar.xz       17-Jan-2017 21:04   63K   Details
[   ] libosmo-netif_0.0.7.20170117.dsc         17-Jan-2017 21:11  1.0K   Details
[   ] libosmo-netif_0.0.7.20170117.tar.xz      17-Jan-2017 21:11  104K   Details
[   ] libosmo-sccp_0.7.1.20170117.dsc          17-Jan-2017 21:14  903    Details
[   ] libosmo-sccp_0.7.1.20170117.tar.xz       17-Jan-2017 21:14   44K   Details
[   ] libosmocore_0.9.6.20170117.dsc           17-Jan-2017 21:01  1.7K   Details
[   ] libosmocore_0.9.6.20170117.tar.xz        17-Jan-2017 21:01  442K   Details
[   ] libsmpp34_1.11.20170117.dsc              17-Jan-2017 20:54  1.0K   Details
[   ] libsmpp34_1.11.20170117.tar.xz           17-Jan-2017 20:54   33K   Details
[   ] openbsc_0.15.1.20170117.dsc              17-Jan-2017 21:22  1.8K   Details
[   ] openbsc_0.15.1.20170117.tar.xz           17-Jan-2017 21:22  624K   Details
[   ] openggsn_0.93.20170117.dsc               17-Jan-2017 21:04  1.0K   Details
[   ] openggsn_0.93.20170117.tar.xz            17-Jan-2017 21:04  101K   Details
[   ] osmo-pcap_0.0.10.20170117.dsc            17-Jan-2017 21:04  793    Details
[   ] osmo-pcap_0.0.10.20170117.tar.xz         17-Jan-2017 21:04   40K   Details
[   ] osmo-pcu_0.3.20170117.dsc                17-Jan-2017 21:07  828    Details
[   ] osmo-pcu_0.3.20170117.tar.xz             17-Jan-2017 21:07  217K   Details
[   ] osmo-sip-connector_1.20170117.dsc        17-Jan-2017 21:07  953    Details
[   ] osmo-sip-connector_1.20170117.tar.xz     17-Jan-2017 21:07   29K   Details

#7 Updated by msuraev almost 3 years ago

The better place to look at is https://build.opensuse.org/project/monitor/network:osmocom:nightly
Right now there are 2 errors one of which has fix under review - see #1860 for details.

#8 Updated by neels almost 3 years ago

  • % Done changed from 90 to 50

msuraev wrote:

The better place to look at is https://build.opensuse.org/project/monitor/network:osmocom:nightly

Agreed. Also my above listings omitted the actual amd64/* and i386/* views which would be more interesting
than the tars.

Looking at https://build.opensuse.org/project/monitor/network:osmocom:nightly :

That page appears like we don't build openbsc i586 on Debian 8 and xUbuntu 16.04?
I have a mail in my inbox complaining about a build failure for openbsc i586 16.04
so I would expect that overview to show a failure there. Confusing.

Trying to look at the cause, it would be helpful to output the test failure logs like
https://jenkins.osmocom.org/jenkins/job/update-osmo-ci-on-slaves/ws/scripts/cat-testlogs.sh/*view*/

Given that the failure is in the db tests
https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/openbsc/xUbuntu_16.04/i586
I would guess wildly that the libdbd-sqlite3 package could be missing,
but it is listed in openbsc_0.15.1.20170118.dsc (checked out with osc).

All in all I still find it hard to understand OBS :-P
Giving up for now, I hope others can help out more productively.

#9 Updated by msuraev almost 3 years ago

neels wrote:

That page appears like we don't build openbsc i586 on Debian 8 and xUbuntu 16.04?

Yes, correct. Once #1592 is merged we should enable it back - see comments below.

I have a mail in my inbox complaining about a build failure for openbsc i586 16.04
so I would expect that overview to show a failure there. Confusing.

I've disabled it recently to save your inbox from further spam.

Given that the failure is in the db tests
https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/openbsc/xUbuntu_16.04/i586
I would guess wildly that the libdbd-sqlite3 package could be missing,
but it is listed in openbsc_0.15.1.20170118.dsc (checked out with osc).

The problem is not with package absence but that some versions of it are plain buggy. Which was partially driver behind #1592 AFAIK.

If everything else builds fine, I'll disable packages affected by libdbi bug until #1592 is merged. We can keep this bug open till than or put a note in #1592 - it's up to you.

#10 Updated by neels almost 3 years ago

Let's have this ticket for current build failures only, so keep this open until osmo-bts is also fixed.
For re-enabling, I've created #1923.

BTW, a better match is #1591 which is specifically about libdbi. Sqlite3 will remain in OsmoNITB
independently from #1592, because we still store SMS with it. We'll drop libdbi use for SMS storage.

#11 Updated by msuraev almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

All current build failures have been resolved.

#12 Updated by laforge over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)