Project

General

Profile

Actions

Feature #1964

closed

osmo-sip-connector: Communicate the failure cause from MNCC to SIP

Added by keith over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/03/2017
Due date:
% Done:

0%

Resolution:
duplicate
Spec Reference:

Description

Bug report or feature request ?

In sip.c:238, we respond SIP_486_BUSY_HERE on call failures.
MNCC communicates to us useful information, as per isdn_cause struct defined in lcr's cause.c IIUC
https://github.com/osmobuntu/lcr/blob/master/cause.c

It'd be nice to implement this.
I tried to get the gsm_mncc object into sip_release_call() to access the gsm_mncc->cause but came up against my deficient knowledge of C. :(

Happy to help otherwise with the copy pasting :)


Related issues

Is duplicate of osmo-sip-connector - Feature #1682: osmo-sip-connector: Add better cause handlingResolvedkeith03/31/2016

Actions
Actions #1

Updated by zecke over 7 years ago

Do you mind if I merge this in to #1682?

Actions #2

Updated by keith over 7 years ago

Ah. Of course! didn't see it.

Actions #3

Updated by zecke over 7 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

Dupliacte of #1682

Actions #4

Updated by zecke over 7 years ago

  • Is duplicate of Feature #1682: osmo-sip-connector: Add better cause handling added
Actions #5

Updated by laforge about 7 years ago

  • Project changed from OpenBSC to osmo-sip-connector
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)