Project

General

Profile

Feature #2194

osmo-gsm-tester: add voice call test

Added by neels over 1 year ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
04/26/2017
Due date:
% Done:

100%

Spec Reference:

Description

Add a test case that performs a voice call (probably in a new test suite called 'voice').
Add various scenario configurations picking phys_chan_config timeslot types (TCH/H, TCH/F, TCH/F_TCH/H_PDCH, TCH/F_PDCH) as well as various voice codecs.
See [[cellular infrastructure:Weekly BTS Tests]] for inspiration.

Concentrate on sysmoBTS so far, and osmo-bts-trx if it already works.
Ignore oct and nanoBTS.


Related issues

Related to OsmoGSMTester - Feature #2197: osmo-gsm-tester: use MNCC interfaceStalled2017-04-26

Has duplicate OsmoGSMTester - Feature #1871: test dynamic timeslotsClosed2016-12-06

Blocked by OsmoGSMTester - Bug #2240: ofono: voice calls are not implemented for any modemClosed2017-05-05

History

#1 Updated by neels over 1 year ago

  • Description updated (diff)

#2 Updated by neels over 1 year ago

#3 Updated by neels over 1 year ago

  • Priority changed from Normal to High

To clarify, this is only about voice call signalling, not about analysis of the actual voice stream or audio sent/received on either side. The test should merely place a call, somehow query that a voice call was launched (maybe implement new CTRL interface queries?) and then hang up.

#4 Updated by neels over 1 year ago

#5 Updated by neels over 1 year ago

#6 Updated by neels over 1 year ago

  • Status changed from New to Closed

replaced by more concise issue #2194

#7 Updated by neels over 1 year ago

  • Is duplicate of deleted (Feature #1871: test dynamic timeslots)

#8 Updated by neels over 1 year ago

  • Status changed from Closed to New

#9 Updated by neels over 1 year ago

#10 Updated by laforge over 1 year ago

  • Assignee deleted (Osmocom Developers)

#11 Updated by laforge over 1 year ago

  • Assignee set to osmo-gsm-tester

#12 Updated by neels over 1 year ago

  • Blocked by Bug #2240: ofono: voice calls are not implemented for any modem added

#13 Updated by pespin over 1 year ago

  • Related to Feature #2197: osmo-gsm-tester: use MNCC interface added

#14 Updated by neels about 1 year ago

  • Priority changed from High to Urgent

#15 Updated by lynxis about 1 year ago

  • Assignee changed from osmo-gsm-tester to pespin

#16 Updated by neels about 1 year ago

  • Parent task deleted (#2193)

#17 Updated by pespin 12 months ago

Basic call is there, still missing to test different time slot and codec configurations.

#18 Updated by laforge 11 months ago

  • Priority changed from Urgent to High

#19 Updated by laforge 2 months ago

pending for one year :/

#20 Updated by neels about 2 months ago

we have voice call tests!? pespin forgot to update the status?

#21 Updated by pespin about 2 months ago

We do have voice tests, but not all of the ones specified in https://osmocom.org/projects/cellular-infrastructure/wiki/Weekly_BTS_Tests. We do test TCH/F, TCH/H, dynamic timeslots, etc. but we don't test different codecs.

So we can say that the important part is done but still some stuff is missing. But given that we still don't support sending data through the modems, we can close the ticket and care about codecs once we have data to send?

#22 Updated by laforge about 2 months ago

On Mon, Aug 20, 2018 at 10:49:32AM +0000, pespin [REDMINE] wrote:

So we can say that the important part is done but still some stuff is missing. But given that we still don't support sending data through the modems, we can close the ticket and care about codecs once we have data to send?

I think whether or not you're transferring user plane ("data is very
ambiguous here), it's still very useful to check if at least the
signaling plane for the different codecs work. You will exercise
different code paths in BTS/BSC/MSC, as well as all the related
signalling messages.

#23 Updated by pespin about 2 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

I submitted several commits which enable testing different timeslot + codec setups during a call:
https://gerrit.osmocom.org/#/c/osmo-gsm-tester/+/10624 suite: Fix generation of config() dictionary
https://gerrit.osmocom.org/#/c/osmo-gsm-tester/+/10621 osmo-bsc: Parametrize codec-list VTY cfg
https://gerrit.osmocom.org/#/c/osmo-gsm-tester/+/10625 default-suites: Add suites testing different codecs
https://gerrit.osmocom.org/#/c/osmo-gsm-tester/+/10626 default-suites: Remove octobts tests

#24 Updated by pespin about 2 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

Merged, closing.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)