Project

General

Profile

Bug #2241

PACCH pagings are omitted

Added by neels over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
Osmocom CNI Developers
Target version:
-
Start date:
05/05/2017
Due date:
% Done:

0%

Spec Reference:

Description

During 33c3 I saw a segfault in the PCU that was most probably introduced by da7250ad2c1cd

My fix wasn't really an improvement, because it caused omittance of pagings that should happen in the lower half of sched_select_ctrl_msg(): b78a4a6dfef
The impact is that CS becomes highly unreliable when GPRS is in use, because it sends pagings via the PCU in case of active GPRS -- which are currently dropped.

I'm fairly sure this patch would fix it: https://gerrit.osmocom.org/2420 -- but then again I was just as sure last time and might be wrong again.

More details are available in the comments to the gerrit patch. At this point I'm mostly not sure whether a non-NULL TBF in case of a NULL msg needs some handling.


Related issues

Is duplicate of OsmoPCU - Bug #2176: CS paging during active PS TBF (regression)Closed04/24/2017

History

#1 Updated by neels over 2 years ago

  • Is duplicate of Bug #2176: CS paging during active PS TBF (regression) added

#2 Updated by neels over 2 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)