Project

General

Profile

Actions

Bug #2293

closed

PCU sock path / cleanup

Added by neels over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
libbsc
Target version:
-
Start date:
05/26/2017
Due date:
% Done:

100%

Resolution:
Spec Reference:

Description

Make sure unix socket paths are placed in the run dir and cleaned up properly.

On the main unit for some reason there was a /tmp/pcu_bts unix socket left behind, blocking newer test runs.
http://jenkins.osmocom.org/jenkins/view/osmo-gsm-tester/job/osmo-gsm-tester_run/130/

It's a bit confusing to me why the OsmoNITB fails with error output about the BTS <-> PCU socket, but this is the output:

01:04:24 run   osmo-nitb_10.42.42.1(pid=8192): stderr:
 | (launched: 2017-05-27_01:04:24)
| 20170527010424567 <001e> telnet_interface.c:95 telnet at 10.42.42.1 4242
| 20170527010424567 <0020> input/ipaccess.c:847 enabling ipaccess BSC mode on 10.42.42.1 with OML 3002 and RSL 3003 TCP ports
| 20170527010424568 <001d> pcu_sock.c:702 Could not create unix socket: Address already in use
| 20170527010424568 <0005> bsc_init.c:548 PCU L1 socket failed for bts 0
| Reading config failed. Exiting. 

When I removed /tmp/pcu_bts, things worked again.

Actions #1

Updated by neels over 5 years ago

  • Description updated (diff)
Actions #3

Updated by laforge over 5 years ago

  • Project changed from OsmoGSMTester to OpenBSC
  • Category set to libbsc
  • Status changed from New to In Progress
  • % Done changed from 0 to 80

Please see https://gerrit.osmocom.org/2777 which removes the notion of a default location for the PCU socket and rather requires the user to explicitly specify the path of where that socket (if any) shall be created for each BTS.

For nanoBTS and OsmoBTS talking to libbsc (OsmoBSC+OsmoNITB) there is no need for a PCU socket at the BSC. This is only required for proprietary legacy BTSs from manufacturers like ERicsson, where the PCU is not inside the BTS but must be co-located with the BSC.

Actions #4

Updated by neels over 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

gerrit#2777 is merged and removes the root cause of this failure.

Actions #5

Updated by laforge over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)