Project

General

Profile

Bug #2338

Fix and re-submit revert commit "RSL: receive and send multiple SI2q messages"

Added by neels over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
06/23/2017
Due date:
% Done:

100%

Spec Reference:

Description

Today we faced consistent osmo-bts-trx failures and Pau traced this back to
commit 340cff51f49f6e798cb5fb6d1b9febdd09902906 in osmo-bts. For the time
being, I pushed a revert of this and a dependent commit.

For details, see commit log of
http://git.osmocom.org/osmo-bts/commit/?id=61f9158eaffd7f4be76f7a44d803d9ba14988d92
http://jenkins.osmocom.org/jenkins/view/osmo-gsm-tester/job/osmo-gsm-tester_run/868/

(closer analysis of the logs and pcaps has not happened yet).

History

#1 Updated by laforge over 2 years ago

  • Assignee set to msuraev
  • Priority changed from Normal to Urgent

#2 Updated by msuraev over 2 years ago

  • Status changed from New to In Progress

It's strange that only *:trx builds are affected: the reverted commits touch only common/ code. I'll investigate further once I have usrp.

#3 Updated by msuraev over 2 years ago

I've reproduced it locally - iphone connects initially but than drops off, acer fails to connect. In the logs I can see multiple:

<0000> rsl.c:2322 (bts=0,trx=0,ts=0,ss=4)(NONE) is not active . Dropping message.
<0000> rsl.c:2322 (bts=0,trx=0,ts=0,ss=4)(NONE) is not active . Dropping message.
<0000> rsl.c:2322 (bts=0,trx=0,ts=0,ss=4)(NONE) is not active . Dropping message.
<0000> rsl.c:2322 (bts=0,trx=0,ts=0,ss=4)(NONE) is not active . Dropping message.
<0000> rsl.c:2322 (bts=0,trx=0,ts=0,ss=4)(NONE) is not active . Dropping message.
<0000> rsl.c:2322 (bts=0,trx=0,ts=0,ss=4)(NONE) is not active . Dropping message.

#4 Updated by msuraev over 2 years ago

  • Tracker changed from Feature to Bug
  • % Done changed from 0 to 40

Gerrit 3047 has been submitted with fixed patch (I've squashed 2 reverted commit into 1 because the 2nd one was fix for coverity issue). In my local tests it fixes the problem.

#5 Updated by msuraev over 2 years ago

  • Status changed from In Progress to Stalled

Local test is ok, osmo-gsm-tester: unable to test due to similar issues with master branch ATM.

#6 Updated by msuraev over 2 years ago

  • Status changed from Stalled to Resolved
  • % Done changed from 40 to 100

#7 Updated by laforge over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)