Project

General

Profile

Actions

Bug #2384

closed

NSVCI=0 seems to cause problems

Added by laforge over 4 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Low
Assignee:
Target version:
-
Start date:
07/20/2017
Due date:
% Done:

100%

Spec Reference:

Description

If I configure NSVCI=0 in omso-bsc.cfg for a given BTS, OsmoPCU will behave eratically in terms of the NS protocol layer towards the SGSN.

Basically, OsmoPCU will at some point decide the NS-VC is no longer alive and refuse NS_ALIVE messages from the SGSN with "NS_STATUS, Cause: PDU not compatible with protocol state"


Related issues

Related to OsmoPCU - Bug #2401: OsmoPCU accepts UDP packets from any sourceCloseddexter07/25/2017

Actions
Related to OsmoPCU - Bug #4111: BSSGP SUSPEND ACK with unknown BVCI=0Resolvedfixeria07/17/2019

Actions
Actions #1

Updated by laforge over 4 years ago

the problem is not 100% reproducible. In som cases, OsmoPCU will send FLOW-CONTROL PDUs every second, in which time the NS-VC stays alive. Only if there are no NS-PDUs exchanged for 60 seconds, OsmoPCU will start rejecting the NS_ALIVE PDU.

So something must be inhibiting the generation of NS_ALIVE in PCU-SGSN direction, as well as inhibiting the FLOW-CONTROL.

Interestingly, "show ns" on the PCU will show

Osmo-PCU# show ns  
Encapsulation NS-UDP-IP     Local IP: 0.0.0.0, UDP Port: 21000
Encapsulation NS-FR-GRE-IP  Local IP: 0.0.0.0
NSEI    96, NS-VC     0, Remote: SGSN, ALIVE UNBLOCKED, UDP         172.31.0.1:23000

Actions #2

Updated by laforge over 4 years ago

  • Priority changed from Normal to Low

this might have been a "false flag" as two SGSNs were sending UDP packets to the PCU simultaneously. This in turn makes me wonder why we would accept UDP packts from a source address that doesn't equal the IP/port specified in the NSVC configuration.

Actions #3

Updated by laforge over 4 years ago

  • Related to Bug #2401: OsmoPCU accepts UDP packets from any source added
Actions #4

Updated by fixeria about 2 years ago

  • Related to Bug #4111: BSSGP SUSPEND ACK with unknown BVCI=0 added
Actions #5

Updated by pespin about 2 months ago

lynxis , daniel is this longer a concern regarding new NS implementation?

Actions #6

Updated by lynxis about 2 months ago

  • Status changed from New to Closed
  • Assignee changed from laforge to lynxis
  • % Done changed from 0 to 100

I would guess it's not anymore a problem. The new implementation checks the UDP source of the packets and NSVCI.
The new code doesn't care if nsvci == 0 or > 0.

I'm closing this for now since it's quite old and needs to be checked again.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)