Project

General

Profile

Actions

Feature #2949

closed

use RR Assignment for Handover within a cell

Added by neels almost 4 years ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/16/2018
Due date:
% Done:

0%

Spec Reference:

Description

Currently, we always use RSL_ACT_INTER_ASYNC and RR Handover Command, both for handover between different cells and for re-assignment within the same cell.

There are patches around to use RSL_ACT_INTRA_IMM_ASS and gsm48_send_rr_ass_cmd() for re-assignment within the same cell, instead.
However, that hasn't worked out in testing so far.

Implement Assignment by actual intra-cell assignment instead of Handover Command.


Related issues

Related to OsmoBSC - Bug #3357: osmo-bsc doesn't perform RSL MODE MODIFY on ASSIGNMENT if channel is compatible.Resolvedsysmocom06/26/2018

Actions
Is duplicate of OsmoBSC - Feature #3277: handover: for intra-cell re-assignment, use Assignment procedure, not HandoverResolvedneels05/17/2018

Actions
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)