Project

General

Profile

Bug #3011

osmo-bts segfaults when osmo-bsc connection goes down

Added by neels almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/27/2018
Due date:
% Done:

0%

Spec Reference:

Description

observed with sysmoBTS:

- register sysmoBTS with osmo-bsc
- kill osmo-bsc
- osmo-bts-sysmo process ends in a segfault

<0012> ../../src/input/ipa.c:69 192.168.0.5:3002 connection closed with server
<000d> ../../../src/common/abis.c:135 Signalling link down
<0001> ../../../src/common/bts.c:238 Shutting down BTS 0, Reason Abis close
<0006> ../../../src/osmo-bts-sysmo/l1_if.c:184 Tx SYS prim DEACTIVATE-RF.req
<0006> ../../../src/osmo-bts-sysmo/oml.c:452 Close TRX 0
<0007> ../../../src/osmo-bts-sysmo/l1_if.c:167 Tx L1 prim MPH-CLOSE.req
<0006> ../../../src/osmo-bts-sysmo/l1_if.c:1209 Rx RF-DEACT.conf (status=Success)
<0006> ../../../src/osmo-bts-sysmo/main.c:120 Set global status #0 to 0 (0001 -> 0000), LEDs: ACT 0
<0001> ../../../src/common/oml.c:344 OC=RADIO-CARRIER INST=(00,00,ff) AVAIL STATE OK -> Off line
<0001> ../../../src/common/oml.c:351 OC=RADIO-CARRIER INST=(00,00,ff) OPER STATE Enabled -> Disabled
<0009> ../../../src/common/pcu_sock.c:663 PCU socket not connected, dropping message
<0001> ../../../src/common/oml.c:312 OC=RADIO-CARRIER INST=(00,00,ff) Tx STATE CHG REP
<0001> ../../../src/common/oml.c:344 OC=BASEBAND-TRANSCEIVER INST=(00,00,ff) AVAIL STATE OK -> Off line
<0001> ../../../src/common/oml.c:351 OC=BASEBAND-TRANSCEIVER INST=(00,00,ff) OPER STATE Enabled -> Disabled
<0009> ../../../src/common/pcu_sock.c:663 PCU socket not connected, dropping message
<0001> ../../../src/common/oml.c:312 OC=BASEBAND-TRANSCEIVER INST=(00,00,ff) Tx STATE CHG REP

Program received signal SIGSEGV, Segmentation fault.
0xb6db9888 in rate_ctr_timer_cb () from /home/root/neels/lib/libosmocore.so.9
(gdb) bt
#0  0xb6db9888 in rate_ctr_timer_cb () from /home/root/neels/lib/libosmocore.so.9
#1  0xb6db0dd4 in osmo_timers_update () from /home/root/neels/lib/libosmocore.so.9
#2  0xb6db148c in osmo_select_main () from /home/root/neels/lib/libosmocore.so.9
#3  0x00039e74 in bts_main ()
#4  0x4b817c18 in __libc_start_main () from /lib/libc.so.6
#5  0x00014058 in _start () at ../sysdeps/arm/start.S:124
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

It's not really that bad, since we're anyway relying on systemd to restart the osmo-bts process after an osmo-bsc has gone. Still the cleanup of an Abis conn seems broken.


Related issues

Related to OsmoBTS - Bug #3137: osmo-bts crash during shutdownResolved04/05/2018

History

#1 Updated by neels almost 2 years ago

doesn't seem to happen all the time either, haven't gotten it reproduced for a long time after the initial failures...

#2 Updated by laforge almost 2 years ago

  • Assignee set to stsp

#3 Updated by neels almost 2 years ago

  • Related to Bug #3137: osmo-bts crash during shutdown added

#4 Updated by neels almost 2 years ago

not sure if #3137 is a duplicate

#5 Updated by stsp over 1 year ago

#6 Updated by stsp over 1 year ago

  • Status changed from New to Resolved

Above patch has been merged.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)