Project

General

Profile

Feature #3047

Test make distcheck and make maintainer-clean works for all projects in jenkins.sh

Added by pespin over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/09/2018
Due date:
% Done:

100%

Spec Reference:

Description

Recently it was reported that osmo-trx make maintainer-clean was broken (already fixed). We should ideally test these during jenkins build, by adding the following bits to all contrib/jenkin.sh:

$MAKE distcheck
$MAKE maintainer-clean

Associated revisions

Revision 5318f43d (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: Ib261f25e2c7b48283a6142259991aadfcf40cdec

Revision 6563cf33 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: I37908c12dae9d268b8bde186e2743a2d7fd13536

Revision 55f03b89 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: Ia6ebe5add2c1ce6891d596fb2987e46f8ff8a6d6

Revision 523862c2 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: I99b9cd46e564cc1c5c1e92b9870368ff515a9356

Revision 89ccf551 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: I6f9274efeb2fdda54feaa54eb299f7aafaaec1eb

Revision 54138657 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: Ic887518bd149f325a92c3517ee90c655b1368fd8

Revision 2ded53c4 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: I6d541b47e68f5a8a61ac139a3ea85a9cb33856c1

Revision 2d7cc611 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: If69a9bddefd74fbdd8003d9efbb4f7756f407037

Revision 04e980dd (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: I9d9b2412f005e4bda0ed35ba715cfb4dca1b04c1

Revision a3dec04c (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: Ic147678e7906a8b9ad7fac8367602b656f4172e6

Revision 471fd921 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: run "make maintainer-clean"

Related: OS#3047
Change-Id: I5c257e21376cdccd6e2f413c7df6dd8caef497f1

Revision 14c80fdb (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: "maintainer-clean" after "publish"

Run "make maintainer-clean" after publishing manuals, not the other way
around. Otherwise jenkins.sh fails when running for the master branch,
because docs/manuals/Makefile gets deleted although it is still needed
to publish the manuals.

Related: OS#3047
Fixes: 471fd92170297f1c857bb448bbf21a162c2ed655 ("contrib/jenkins.sh: run "make maintainer-clean"")
Change-Id: I8ba5369b0948b61c68f43d807312c52465119aa5

Revision fdff85b8 (diff)
Added by osmith over 2 years ago

contrib/jenkins.sh: "maintainer-clean" after "publish"

Run "make maintainer-clean" after publishing manuals, not the other way
around. Otherwise jenkins.sh fails when running for the master branch,
because docs/manuals/Makefile gets deleted although it is still needed
to publish the manuals.

Related: OS#3047
Fixes: 55f03b898a3113f7b73a3abd1c2dfe2edd6135ac ("contrib/jenkins.sh: run "make maintainer-clean"")
Change-Id: I8bcee9069743b76966a78e1c13d0be9ba62d992c

History

#1 Updated by pespin over 3 years ago

  • Description updated (diff)

#2 Updated by laforge over 2 years ago

  • Assignee set to osmith

#3 Updated by osmith over 2 years ago

  • Status changed from New to In Progress

#4 Updated by osmith over 2 years ago

  • % Done changed from 0 to 50

Initial batch of patches submitted:
https://gerrit.osmocom.org/q/topic:make-maintainer-clean

For some repositories, the CI test is failing, which mostly means that "make maintainer-clean" is actually broken there. I'm looking into fixing those.

While I was at it, I have also prepared patches to add a jenkins.sh script to libosmo-dsp (right now, the autoreconf -fi, ./configure, make etc. commands are hardcoded in master-builds.yml). And another patch to enable gerrit-verifications for all repositories that were only enabled in master-builds.yml.

laforge, it seems that I lack permissions to push patches to gerrit for the following repositories. Can you give me the permissions, so I can submit all patches I have prepared?
  • libosmo-dsp
  • osmo-gmr
  • rtl-sdr

#5 Updated by laforge over 2 years ago

osmith wrote:

laforge, it seems that I lack permissions to push patches to gerrit for the following repositories. Can you give me the permissions, so I can submit all patches I have prepared?
  • libosmo-dsp
  • osmo-gmr
  • rtl-sdr

those three projects are not written/maintained by sysmocom but are maintained by the respective developers tnt and @steve-m. Its up to the respective authors/maintainers to decide who should have comit access to those repositories. The classic approach is to use git send-email to the respective mailing list + maintainer.

#6 Updated by osmith over 2 years ago

  • % Done changed from 50 to 90

I've sent out the patches to the maintainers directly (will use the respective mailing lists next time). Furthermore I've pushed a patch to fix "make distcheck" in libusrp and osmo-ci patches to enable libtelnet in gerrit-veritifcations and to use contrib/jenkins.sh for libosmo-dsp. When these last patches are merged, then the issue is done:

https://gerrit.osmocom.org/q/topic:make-maintainer-clean+status:open

#7 Updated by osmith over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)