Project

General

Profile

Bug #3072

osmo-gsm-manuals fail to build since docbook.org move to https

Added by laforge 9 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/17/2018
Due date:
% Done:

100%

Spec Reference:

Description

Since a few days ago, docbook.org is redirecting their http URLs to https:

wget http://www.docbook.org/xml/5.0/dtd/docbook.dtd
--2018-03-17 13:53:39--  http://www.docbook.org/xml/5.0/dtd/docbook.dtd
Resolving www.docbook.org (www.docbook.org)... 54.93.128.64
Connecting to www.docbook.org (www.docbook.org)|54.93.128.64|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://docbook.org/xml/5.0/dtd/docbook.dtd [following]
--2018-03-17 13:53:39--  https://docbook.org/xml/5.0/dtd/docbook.dtd
Resolving docbook.org (docbook.org)... 54.93.128.64
Connecting to docbook.org (docbook.org)|54.93.128.64|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 198540 (194K) [application/xml-dtd]
Saving to: ‘docbook.dtd’

it appears that xmllint is not able to do https:

socket(AF_INET, SOCK_DGRAM|SOCK_CLOEXEC|SOCK_NONBLOCK, IPPROTO_IP) = 3
connect(3, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.100.1")}, 16) = 0
poll([{fd=3, events=POLLOUT}], 1, 0)    = 1 ([{fd=3, revents=POLLOUT}])
sendmmsg(3, [{msg_hdr={msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\364A\1\0\0\1\0\0\0\0\0\0\3www\7docbook\3org\0\0\1\0"..., iov_len=33}], msg_iovlen=1, msg_controllen=0, msg_flags=0}, msg_len=33}, {msg_hdr={msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="XW\1\0\0\1\0\0\0\0\0\0\3www\7docbook\3org\0\0\34\0"..., iov_len=33}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_DONTWAIT|MSG_FIN|MSG_CONFIRM|MSG_RST|MSG_WAITFORONE|0x93020010}, msg_len=33}], 2, MSG_NOSIGNAL) = 2
poll([{fd=3, events=POLLIN}], 1, 5000)  = 1 ([{fd=3, revents=POLLIN}])
ioctl(3, FIONREAD, [202])               = 0
recvfrom(3, "\364A\201\200\0\1\0\1\0\4\0\4\3www\7docbook\3org\0\0\1\0"..., 2048, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.100.1")}, [28->16]) = 202
poll([{fd=3, events=POLLIN}], 1, 4998)  = 1 ([{fd=3, revents=POLLIN}])
ioctl(3, FIONREAD, [98])                = 0
recvfrom(3, "XW\201\200\0\1\0\0\0\1\0\0\3www\7docbook\3org\0\0\34\0"..., 65536, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("192.168.100.1")}, [28->16]) = 98
close(3)                                = 0
socket(AF_INET, SOCK_STREAM, IPPROTO_TCP) = 3
fcntl(3, F_GETFL)                       = 0x2 (flags O_RDWR)
fcntl(3, F_SETFL, O_RDWR|O_NONBLOCK)    = 0
connect(3, {sa_family=AF_INET, sin_port=htons(80), sin_addr=inet_addr("54.93.37.149")}, 16) = -1 EINPROGRESS (Operation now in progress)
poll([{fd=3, events=POLLOUT}], 1, 60000) = 1 ([{fd=3, revents=POLLOUT}])
getsockopt(3, SOL_SOCKET, SO_ERROR, [0], [4]) = 0
sendto(3, "GET /xml/5.0/dtd/docbook.dtd HTT"..., 87, 0, NULL, 0) = 87
recvfrom(3, 0x5644e9ec7a70, 4096, 0, NULL, NULL) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}], 1, 60000) = 1 ([{fd=3, revents=POLLIN}])
recvfrom(3, "HTTP/1.0 301 Moved Permanently\r\n"..., 4096, 0, NULL, NULL) = 307
recvfrom(3, "", 4096, 0, NULL, NULL)    = 0
close(3)                                = 0
write(2, "error : ", 8error : )                 = 8
write(2, "Unknown IO error\n", 17Unknown IO error
)      = 17
stat("http://www.docbook.org/xml/5.0/dtd/docbook.dtd", 0x7ffe930323d0) = -1 ENOENT (No such file or directory)

History

#1 Updated by laforge 9 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

See also https://github.com/gentoo/dotnet/issues/178

A suggested workaround is to use the local catalog, i.e. install "docbook5-xml" on debian/ubuntu. That doesn't immediately work as we're using "http://www.docbook.org" and not "http://docbook.org" as prefix, and hence the catalog doesn't match.

#2 Updated by laforge 9 months ago

the workaround appears to work, I've added the "docbook5-xml" package via apt to the deb8build lxc's on build1+build2. ansible in https://gerrit.osmocom.org/7342

#3 Updated by laforge 9 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

closing due to having found + deployed a workaround with local catalog.

Real upstream bug seems to be https://bugzilla.gnome.org/show_bug.cgi?id=791220

#4 Updated by neels 5 months ago

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)