Project

General

Profile

Actions

Bug #3179

closed

osmo-bsc_nat TTCN-3 tests not yet executed automatically

Added by laforge almost 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
04/16/2018
Due date:
% Done:

100%

Spec Reference:
Tags:

Description

Daniel + I developed some tets for mgw-nat in January. Those tests are partially related to the new "multiple MSC" feature of osmo-bsc_nat, but it should be easy to split the tests into "single MSC" and "multi MSC" tests.

The tests should be dockerized and executed in the same fashion as we execute the other ttcn3 tests from jenkins.osmocom.org once every 24h.

Please start by talking to daniel about the status of those tests, and whether you should use master or some branch in osmo-ttcn3-hacks, whether that branch should be reviewed/merged/...

Actions #1

Updated by laforge over 3 years ago

  • Tags set to TTCN3
Actions #2

Updated by pespin over 3 years ago

  • Status changed from New to Feedback
  • Assignee changed from pespin to daniel

Assigning to Daniel so he can write here a brief description on the status of the different pieces as well as some links/pointer to the related code and tests.

Actions #3

Updated by daniel over 3 years ago

  • Status changed from Feedback to New
  • Priority changed from Normal to High
Actions #4

Updated by daniel over 3 years ago

  • Status changed from New to In Progress

Working on this now. I already fixed some issues due to bit rot.

Actions #5

Updated by daniel about 3 years ago

  • % Done changed from 0 to 40

bscnat tests for docker are in https://gerrit.osmocom.org/#/c/docker-playground/+/11657

The tests themselves still fail with a strange "Decoding of integer value failed" error. I have asked for help on the Eclipse Titan forums and will link to the thread once it passes through moderator approval.

Actions #7

Updated by daniel almost 3 years ago

  • Subject changed from mgw-nat TTCN-3 tests not yet executed automatically to osmo-bsc_nat TTCN-3 tests not yet executed automatically

I have tried to debug the ttcn3 code some more.

Compiling with ttcn3-compiler option -n (which enables the ttcn3 debugger) just fails with

BSSMAP_Emulation.cc:10699:162: error: macro "DEBUGGER_STORE_RETURN_VALUE" passed 4 arguments, but takes just 2                        
 return DEBUGGER_STORE_RETURN_VALUE(tmp_13, const_cast< const VALUE_ARRAY<ConnectionData, 16, 0>&>(BSSMAP__Emulation__CT_component_ConnectionTable)[i].comp__ref());

The good news is that the issue doesn't seem to happen when using eclipse-titan version 6.5.0-1 from debian testing/buster.

The docker images currently use eclipse-titan version 6.3.1-1 from the Osmocom OBS repository.
I think we downgraded because of some TTCN3.hh include error in jenkins. I'll try and fix that so we can run the bscnat tests in jenkins (instead of wasting more time debugging the ttcn3 issue).

Actions #8

Updated by laforge almost 3 years ago

On Wed, Feb 13, 2019 at 04:52:36PM +0000, daniel [REDMINE] wrote:

The docker images currently use eclipse-titan version 6.3.1-1 from the Osmocom OBS repository.
I think we downgraded because of some TTCN3.hh include error in jenkins. I'll try and fix that so we can run the bscnat tests in jenkins (instead of wasting more time debugging the ttcn3 issue).

see my laforge/titan65x branch. However, I guess it needs to be modified to ensure our
scripts work both with 6.4.0 and earlier, as well as 6.5.x

I assume it's less an incompatibility of TITAN itself, but rather related to how
debian packages it (path names, ...)

Actions #9

Updated by daniel almost 3 years ago

As far as I see it the issue is that we need to omit some of the sed magic in our regen_makefile.sh

I'll try to make it aware of different ttcn3 versions

Actions #10

Updated by daniel almost 3 years ago

https://gerrit.osmocom.org/#/c/osmo-ttcn3-hacks/+/12908/

Patch is merged, now we need to use the newer ttcn3 version in jenkins.

Actions #11

Updated by daniel almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)