Project

General

Profile

Bug #3254

OsmoBTS doesn't reject RSL CHAN ACT for unsupported ciphers

Added by laforge over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
05/09/2018
Due date:
% Done:

100%

Spec Reference:

Description

When using an unsupported cipher, the RSL CHAN ACT should result in a RSL CHAN ACT NACK due to the unsupported cipher.

However, OsmoBTS instead simply acknowledges the channel activation and activates the channel with A5/0. This is actually the underlying cause of #3253


Related issues

Related to OsmoBTS - Bug #3253: osmo-bts-trx doesn't enable A5/3Resolved05/09/2018

History

#1 Updated by laforge over 1 year ago

  • Related to Bug #3253: osmo-bts-trx doesn't enable A5/3 added

#2 Updated by laforge over 1 year ago

  • % Done changed from 0 to 30

The problem is encr_info2lchan() which uses bts_supports_cipher() to determine if the cipher is suppored. However, if bts_supports_cipher() returns 0 (not supported), it uses this value as return value of encr_info2lchan() where '0' means success (standard osmocom convention). This results in channel activation proceeding, which it shouldn't.

#3 Updated by laforge over 1 year ago

  • Status changed from New to In Progress
  • % Done changed from 30 to 80

#4 Updated by laforge over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)