Project

General

Profile

Bug #3358

TC_lcls_connect_break, TC_lcls_connect_clear, TC_lcls_gcr_bway_connect, and TC_lcls_gcr_bway_dont_connect_csc fail

Added by dexter almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
06/26/2018
Due date:
% Done:

100%

Spec Reference:

Description

The following LCLS tests fail:

BSC_Tests_LCLS.TC_lcls_connect_break
BSC_Tests_LCLS.TC_lcls_connect_clear
BSC_Tests_LCLS.TC_lcls_gcr_bway_dont_connect_csc

The tests fail because is for the same for all three tests:
"Received non-matching ASSIGNMENT COMPLETE"

All three tests expect the following ASSIGNMENT COMPLETE:

14:06:55.266136 10 MSC_ConnectionHandler.ttcn:842 {
    discriminator := '0'B,
    spare := '0000000'B,
    dlci := *,
    lengthIndicator := ?,
    pdu := {
        bssmap := {
            assignmentComplete := {
                messageType := '02'O,
                rR_Cause := *,
                circuitIdentityCode := omit,
                cellIdentifier := *,
                chosenChannel := *,
                chosenEncryptionAlgorithm := *,
                circuitPool := *,
                speechVersion := *,
                lSAIdentifier := *,
                talkerPriority := *,
                aoIPTransportLayer := ?,
                speechCodec := *,
                codecList := *,
                lCLS_BSS_Status := {
                    elementIdentifier := '8D'O,
                    lCLS_BSS_StatusValue := '0001'B,
                    spare := '0000'B
                }
            }
        }
    }
}

For all three tests, osmo-bsc sends the following message:

 @BSSAP_Types.PDU_BSSAP : {
    discriminator := '0'B,
    spare := '0000000'B,
    dlci := omit,
    lengthIndicator := 20,
    pdu := {
        bssmap := {
            assignmentComplete := {
                messageType := '02'O,
                rR_Cause := {
                    elementIdentifier := '15'O,
                    rr_Cause := '00'O
                },
                circuitIdentityCode := omit,
                cellIdentifier := omit,
                chosenChannel := {
                    elementIdentifier := '21'O ("!"),
                    channel := '0000'B,
                    channelMode := '0000'B
                },
                chosenEncryptionAlgorithm := {
                    elementIdentifier := '2C'O (","),
                    algorithmIdentifier := '01'O
                },
                circuitPool := omit,
                speechVersion := {
                    elementIdentifier := '40'O ("@"),
                    speechVersionIdentifier := '0000001'B,
                    spare1_1 := '0'B
                },
                lSAIdentifier := omit,
                talkerPriority := omit,
                aoIPTransportLayer := {
                    elementIdentifier := '7C'O ("|"),
                    lengthIndicator := 6,
                    ipAddress := {
                        ipv4 := '7F000003'O
                    },
                    uDPPortValue := 11002
                },
                speechCodec := {
                    elementIdentifier := '7E'O ("~"),
                    lengthIndicator := 1,
                    codecElements := {
                        {
                            codecType := GSM_FR (0),
                            tF := '0'B,
                            pT := '0'B,
                            pI := '0'B,
                            fI := '1'B,
                            extendedCodecType := omit,
                            s0_7 := omit,
                            s8_15 := omit
                        }
                    }
                },
                codecList := omit,
                lCLS_BSS_Status := omit
            }
        }
    }
}

We can see that the lCLS_BSS_Status is missing. This is why the testcases fail.

Notw: The problem is also reproduceable using the follwing git state, which
is just before the mgw/mgcp_client changes were merged.
osmo-mgw:5928dc93457982212a7d088c41002363db330451
osmo-bsc:f8cf5263f9d7659e4c790a3606f2b8c1ee0cfdbc

Associated revisions

Revision 116e05e9 (diff)
Added by dexter almost 3 years ago

lcls: set codec info when performing MGW operation

While GSCON is setting the codec info when operating on the MGW, LCLS
is not doing that yet. This means that the MDCX messages that are
sent by LCLS do not contain any payload type and also no ptime or
rtpmap fields. This also causes the following TTCN3 tests to fail:

TC_lcls_connect_break
TC_lcls_connect_clear
TC_lcls_gcr_bway_connect
TC_lcls_gcr_bway_dont_connect_csc

- Make mgcp_pick_codec() public as bsc_subscr_pick_codec()
- use bsc_subscr_pick_codec() to set codec info in osmo_bsc_lcls.c

Change-Id: I383d55fa602cda0926dd701ee517a299db578260
Closes: OS#3358

History

#1 Updated by dexter almost 3 years ago

  • Subject changed from TC_lcls_connect_break, BSC_Tests_LCLS and BSC_Tests_LCLS fail to TC_lcls_connect_break, TC_lcls_connect_clear, TC_lcls_gcr_bway_connect, and TC_lcls_gcr_bway_dont_connect_csc fail

#2 Updated by dexter almost 3 years ago

BSC_Tests_LCLS.TC_lcls_gcr_bway_connect has also the same problem.

#3 Updated by dexter almost 3 years ago

  • Status changed from New to In Progress

I have also found another problem and this is why the jenkins is failing (I do not have any clue yet why it fails different on my side). However. In osmo_bsc_lcls.c the codec info is still not set. I was not aware that osmo_bsc_lcls.c is doing MGW actions on the side. I thought that LCLS would somehow interact with GSCON. I am fixing this now.

#4 Updated by dexter almost 3 years ago

  • % Done changed from 0 to 100

I have now added the missing codec info and re-tested everything in docker. The LCLS tests now look fine again.

See also:
https://gerrit.osmocom.org/#/c/osmo-bsc/+/9747 lcls: set codec info when performing MGW operation

#5 Updated by dexter almost 3 years ago

Note: I still do not know why the LCLS fail so badly when I test locally. Presumably this is due to some problem with my environment.

#6 Updated by dexter almost 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)