Project

General

Profile

Bug #3381

osmo-ggsn does not react properly when the PDP CTX ACT PCO contains primary and secondary DNS in separate IPCP

Added by dexter 11 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
-
Start date:
07/05/2018
Due date:
% Done:

100%

Spec Reference:

Description

When a PDP CONTEXT ACTIVATE message with a PCO that contains Primary and Secondary DNS in separate IPCP containers is recaived, then only the first of the two containers is interpreted and the second one is ignored.

Since almost all phones send PDP CONTEXT ACTIVATES where primary and secondary is in a single IPCP container this is quite a corner case situation. However some phones (e.g. Blackberry 9780) behave different.

problematic_packet.pcapng problematic_packet.pcapng 548 Bytes dexter, 07/05/2018 09:25 AM

Related issues

Is duplicate of OsmoGGSN (former OpenGGSN) - Bug #3319: also handle PCOs that contain primary and secondary DNS in two separate IPCP containersResolved2018-06-04

History

#1 Updated by dexter 10 months ago

  • Assignee changed from dexter to pespin

#2 Updated by dexter 10 months ago

Note: #3381 #3319 are duplicates

#3 Updated by pespin about 1 month ago

  • Is duplicate of Bug #3319: also handle PCOs that contain primary and secondary DNS in two separate IPCP containers added

#4 Updated by pespin about 1 month ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

This is a duplicate, and the related ticket was resolved already.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)