Project

General

Profile

Bug #3661

latest stable packages report "UNKNOWN" as version string in --version

Added by osmith 8 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
10/17/2018
Due date:
% Done:

100%

Spec Reference:

Description

A jenkins job was implemented in #3555 to check for "UNKNOWN" in the --version output, and it is running through for nightly. But in "latest stable" it is failing.

Example:
https://jenkins.osmocom.org/jenkins/job/Osmocom-Debian-install-latest/43/console

Slightly off topic: right now nobody receives notifications if the -latest or -nightly job fails, should we change this (after the issue is fixed)?


Related issues

Related to Cellular Network Infrastructure - Bug #3449: network:osmocom:nightly packages have VERSION="UNKNOWN"Resolved08/06/2018

Related to Cellular Network Infrastructure - Feature #3555: debian-repo-install-test: check if binaries report UNKNOWN as version stringResolved09/14/2018

History

#1 Updated by osmith 8 months ago

  • Related to Bug #3449: network:osmocom:nightly packages have VERSION="UNKNOWN" added

#2 Updated by osmith 8 months ago

  • Related to Feature #3555: debian-repo-install-test: check if binaries report UNKNOWN as version string added

#3 Updated by laforge about 2 months ago

  • Priority changed from Normal to Urgent

#4 Updated by osmith about 1 month ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

The job is not failing anymore since 3 months ago, and notifications are working (checked my e-mail notifications dir, it has some from this job).

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)