Project

General

Profile

Bug #3800

Core file breaks jenkins ttcn3 builds

Added by daniel over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
02/13/2019
Due date:
% Done:

100%

Spec Reference:

Description

ttcn3 jenkins jobs fail if the tested component crashes with a core dump.

The issue is that docker runs (for example) osmo-msc as root and if it crashes the core dump generated is also owned by root - but without read permissions for others. Then the jenkins task that collects the artifacts runs as user and fails to read the core file. The log file is also owned by root, but since it is readable by all it can be archived.

https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-msc-test/438/consoleFull

The workspace of osmo-msc-test shows the core file and also shows that it can't be read by jenkins.

One possibility would be to run osmo-msc inside docker as user instead of root, but then you need to ensure that uid inside and outside of docker match. Fixuid seems to do exactly that: https://github.com/boxboat/fixuid

We could just sudo chown -R $USER $VOL_BASE_DIR in jenkins.sh or in the jenkins job after running jenkins.sh if we don't want to have it in the script.


Related issues

Related to OsmoMSC - Bug #3811: ttcn3-msc-test-latest fails since february 19Closed02/20/2019

Associated revisions

Revision 4cc75279 (diff)
Added by daniel about 2 years ago

Fix permissions when collecting logs

Use the debian-jessie-build container to ensure all files under
${VOL_BASE_DIR} are readable.
Call this directly from collect_logs so we handle all ttcn3 jobs.

Fixes: OS#3800
Change-Id: I124c554eee69ec5586547d3c96b8ec571e0653a7

History

#1 Updated by daniel about 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

I'm calling docker with chown since some other ideas (suid binary) didn't really seem to work as expected

Patch is in Gerrit:

https://gerrit.osmocom.org/#/c/docker-playground/+/13008

#2 Updated by daniel about 2 years ago

It seems that ttcn3-msc-test-latest needs some care before it can run again:
https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-msc-test-latest/

The above patch should also fix such issues in the future.

#3 Updated by laforge about 2 years ago

On Fri, Feb 22, 2019 at 06:07:56PM +0000, daniel [REDMINE] wrote:

It seems that ttcn3-msc-test-latest needs some care before it can run again:
https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-msc-test-latest/

I've manually removed the files and re-triggered a build.

The above patch should also fix such issues in the future.

The patch should be merged now, thanks.

#4 Updated by daniel about 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Should be resolved now, though osmo-msc doesn't seem to crash anymore.

#5 Updated by daniel about 2 years ago

  • Related to Bug #3811: ttcn3-msc-test-latest fails since february 19 added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)