Project

General

Profile

Bug #3869

osmo-mgw-test job fails since build 544

Added by laforge over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
03/28/2019
Due date:
% Done:

100%

Spec Reference:
Tags:

Description

Since Build 544, osmo-mgw-test is failing, see https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-mgw-test/544/

The problem appears to be that there is no "docker pull debian:jessie" before re-building the debian jessie based containers in our docker-playground. As a result, we're basing off an old jessie image, which still has APT feeds installed that have been deactivated by the Debian project as of March 24th.

Pleaes make sure that for those Dockerfiles that require external dependencies we will actually "pull" the latest such image before building them. The same applies at the very least also to debian:stretch

History

#1 Updated by laforge over 1 year ago

btw: I just manually pulled those images, but that's of course not the generic solution and just a short-term workaround to get our tests going again.

#2 Updated by osmith over 1 year ago

This issue has just caused the update-osmo-ci-on-slaves job to fail, so I'm looking into it now.

(Can't change the status to "in progress", missing permissions?)

#3 Updated by osmith over 1 year ago

osmith wrote:

This issue has just caused the update-osmo-ci-on-slaves job to fail, so I'm looking into it now.

This is a different issue: #3894

But since I was at it, this patch fixes the problem described in this issue:

https://gerrit.osmocom.org/#/c/docker-playground/+/13480/

#4 Updated by osmith over 1 year ago

Related patch for the osmo-ci job (which also did not update the images, but as I wrote, this is not the reason why it failed): https://gerrit.osmocom.org/#/c/osmo-ci/+/13486

#5 Updated by osmith over 1 year ago

Patch is merged, this can be set to resolved. (I don't have enough permissions in this redmine project.)

#6 Updated by laforge over 1 year ago

On Tue, Apr 02, 2019 at 08:32:23AM +0000, osmith [REDMINE] wrote:

(Can't change the status to "in progress", missing permissions?)

should be fixed.

#7 Updated by osmith over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

yep :)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)