Project

General

Profile

Actions

Bug #3938

closed

Get Attribute Response parsing is broken: NM_ATT_SW_DESCR is ignored

Added by fixeria almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
04/18/2019
Due date:
% Done:

100%

Spec Reference:
3GPP TS 52.021

Description

For some reason, OsmoBSC doesn't parse the attribute 'NM_ATT_SW_DESCR' from 'Get Attributes Response':

DNM DEBUG <0004> abis_nm.c:1716 Get Attr (bts=0,trx=255)
DNM DEBUG <0004> abis_nm.c:1716 Get Attr (bts=0,trx=0)

...

DNM DEBUG <0004> abis_nm.c:621 OC=BTS(01) INST=(00,ff,ff): Get Attributes Response for BTS0
DNM DEBUG <0004> abis_nm.c:489 BTS0 Get Attributes Response Info: 70 bytes total with 0 unreported attributes
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'EGPRS' reported via OML does not match statically set feature: 0 != 1. Please fix.
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'OML Alerts' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'CBCH' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'Fullrate speech V1' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'Halfrate speech V1' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'Fullrate speech EFR' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'Fullrate speech AMR' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0004> abis_nm.c:538 BTS0 feature 'Halfrate speech AMR' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM DEBUG <0004> abis_nm.c:621 OC=BTS(01) INST=(00,ff,ff): Get Attributes Response for BTS0
DNM DEBUG <0004> abis_nm.c:489 BTS0 Get Attributes Response Info: 32 bytes total with 1 unreported attributes
DNM ERROR <0004> abis_nm.c:494 BTS0 Attribute Manufacturer Dependent State is unreported

while the old OpenBSC does:

DNM DEBUG <0005> abis_nm.c:1601 Get Attr (bts=0)
DNM DEBUG <0005> abis_nm.c:1601 Get Attr (bts=0)

...

DNM DEBUG <0005> abis_nm.c:550 OC=BTS(01) INST=(00,ff,ff) Get Attributes Response for BTS0
DNM DEBUG <0005> abis_nm.c:463 BTS0 Get Attributes Response Info: 70 bytes total with 0 unreported attributes
DNM NOTICE <0005> abis_nm.c:507 BTS0 feature 'EGPRS' reported via OML does not match statically set feature: 0 != 1. Please fix.
DNM NOTICE <0005> abis_nm.c:507 BTS0 feature 'OML Alerts' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0005> abis_nm.c:507 BTS0 feature 'CBCH' reported via OML does not match statically set feature: 1 != 0. Please fix.
DNM NOTICE <0005> abis_nm.c:573 BTS0: ARI reported sw[0/2]: osmobts is 0.8.1.255-7209
DNM NOTICE <0005> abis_nm.c:446 BTS0 reported variant: omso-bts-trx
DNM DEBUG <0005> abis_nm.c:550 OC=BTS(01) INST=(00,ff,ff) Get Attributes Response for BTS0
DNM DEBUG <0005> abis_nm.c:463 BTS0 Get Attributes Response Info: 32 bytes total with 1 unreported attributes
DNM ERROR <0005> abis_nm.c:468 BTS0 Attribute Manufacturer Dependent State is unreported
DNM NOTICE <0005> abis_nm.c:573 BTS0: ARI reported sw[0/1]: TRX_PHY_VERSION is Unknown

Observed with the recent osmo-bts-trx 0.8.1.255-7209.

Please find the OML captures for both cases attached. I could't find any difference in both pairs of 'Get Attributes' / 'Get Attributes Response' messages. The following is my hand-parsed representation of these messages:

OML BTS(ff,ff,ff) Get Attributes
RAW: 1e41

OML BTS(00,ff,ff) Get Attributes Response
RAW (len=70): 001e000242fc421200076f736d6f62747313000e302e382e312e3235352d37323039421200104254535f545950455f56415249414e5413000c6f6d736f2d6274732d74727800

0000  00 1e 00 02 42 fc 42 12  00 07 6f 73 6d 6f 62 74   ....B.B. ..osmobt
0010  73 13 00 0e 30 2e 38 2e  31 2e 32 35 35 2d 37 32   s...0.8. 1.255-72
0020  30 39 42 12 00 10 42 54  53 5f 54 59 50 45 5f 56   09B...BT S_TYPE_V
0030  41 52 49 41 4e 54 13 00  0c 6f 6d 73 6f 2d 62 74   ARIANT.. .omso-bt
0040  73 2d 74 72 78 00                                  s-trx.

00 - the amount of unreported attributes

1e - NM_ATT_MANUF_ID
    0002 - 2 octets
    42fc - BTS supported features

42 - NM_ATT_SW_DESCR
    12 - NM_ATT_FILE_ID
        0007 - 7 octets
        6f736d6f627473 - "osmobts" 
    13 - NM_ATT_FILE_VERSION
        000e - 14 octets
        302e382e312e3235352d37323039 - "0.8.1.255-7209" 

42 - NM_ATT_SW_DESCR
    12 - NM_ATT_FILE_ID
        0010 - 16 octets
        4254535f545950455f56415249414e54 - "BTS_TYPE_VARIANT" 
    13 - NM_ATT_FILE_VERSION
        000c - 13 octets
        6f6d736f2d6274732d74727800 - "osmo-bts-trx" + \0

OML Baseband Transceiver(00,00,ff) Get Attributes
RAW: 1c41

OML BTS(00,ff,ff) Get Attributes Response
RAW (len=32): 011c4212000f5452585f5048595f56455253494f4e130007556e6b6e6f776e00

0000  01 1c 42 12 00 0f 54 52  58 5f 50 48 59 5f 56 45   ..B...TR X_PHY_VE
0010  52 53 49 4f 4e 13 00 07  55 6e 6b 6e 6f 77 6e 00   RSION... Unknown.

01 - the amount of unreported attributes
1c - NM_ATT_MANUF_STATE

42 - NM_ATT_SW_DESCR
    12 - NM_ATT_FILE_ID
        000f - 15 octets
        5452585f5048595f56455253494f4e - "TRX_PHY_VERSION" 
    13 - NM_ATT_FILE_VERSION
        0007 - 7 octets (WTF?!? \0 is not accounted)
        556e6b6e6f776e00 - "Unknown" + \0

I am not familiar with OML, though I found some things odd:

  • In the first 'Get Attributes' message we ask for 0x1e - NM_ATT_MANUF_ID and 0x41 - NM_ATT_SW_CONFIG. However, instead of 0x41 - NM_ATT_SW_CONFIG we receive 0x42 - NM_ATT_SW_DESCR in the response. Same problem with the second 'Get Attributes Response' message.
  • In the first 'Get Attributes Response' message, 'NM_ATT_SW_DESCR' tag is present twice. Is it allowed to indicate the same tag twice?
  • In the first 'Get Attributes Response' message, one value of 'NM_ATT_FILE_VERSION' is \0-terminated, another is not.
  • In the second 'Get Attributes Response' message, the value of 'NM_ATT_FILE_VERSION' is \0-terminated, but \0 is not accounted in the TLV's length.
  • The secound 'Get Attributes' message is for Baseband Transceiver (00,00,ff), however the response is for BTS (00,ff,ff).

Files

abis_oml_open_bsc.pcapng.gz abis_oml_open_bsc.pcapng.gz 4.02 KB fixeria, 04/18/2019 08:26 AM
abis_oml_osmo_bts.pcapng.gz abis_oml_osmo_bts.pcapng.gz 4.09 KB fixeria, 04/18/2019 08:26 AM

Related issues

Related to OsmoBSC - Bug #1614: better identification of BTS model / capabilities to BSCStalled02/23/2016

Actions
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)