Project

General

Profile

Bug #4314

OsmoBSC build failures on OBS after using inkscape in doc build

Added by laforge about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
12/07/2019
Due date:
% Done:

100%

Spec Reference:

Description

We have tons of build failures for osmo-bsc.

  • Debian 9, 10, Testing, Unstable and Ubuntu 18.04, 18.10, 19.04, 19.10 all somehow fail to create the image
    https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/osmo-bsc/Debian_9.0/i586
    [  216s] asciidoc: osmux-reference.adoc: line 410: evaluating: {counter2:target-numa2x: ERROR: "dblatex" -t pdf -p "/etc/asciidoc/dblatex/asciidoc-dblatex.xsl" -s "/etc/asciidoc/dblatex/asciidoc-dblatex.sty" -s /usr/share/osmo-gsm-manuals/build/custom-dblatex.sty -P draft.mode=yes -P draft.watermark=0 -V  "/usr/src/packages/BUILD/doc/manuals/osmux-reference.xml" returned non-zero exit status 1
    

History

#1 Updated by osmith about 2 months ago

  • Status changed from New to In Progress

#2 Updated by osmith about 2 months ago

  • % Done changed from 0 to 90

The problem is, that inkscape is not installed. Therefore, the SVG graphic can not be embedded into the manual, and the build fails.

Ubuntu 16.04 has no inkscape altogether:

The error message is misleading, because there is an inkscape package:
https://packages.ubuntu.com/xenial/inkscape

Patch submitted to add inkscape to the depends of osmo-gsm-manuals:
https://gerrit.osmocom.org/c/osmo-gsm-manuals/+/16522

#3 Updated by osmith about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)