Project

General

Profile

Support #4358

CalypsoBTS: No satisfactory response from transceiver

Added by enceladusspace 8 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
CalypsoBTS
Target version:
-
Start date:
01/11/2020
Due date:
% Done:

0%

Resolution:
Spec Reference:

Description

Good evening, Moscow time, I’m still a beginner in your project, but have already learned something, stopped at one of the stages, I get the following output in the terminal (I attach the screenshot and output) I use the configuration files with github, how do I gradually correct the settings and files?

root@space:~/.osmocom# osmo-nitb -c ~/.osmocom/open-bsc.cfg -l ~/.osmocom/hlr.sqlite3 -P -C --debug=DRLL:DCC:DMM:DRR:DRSL:DNM
<001e> telnet_interface.c:104 Available via telnet 127.0.0.1 4242
<0020> input/ipaccess.c:863 enabling ipaccess BSC mode on 0.0.0.0 with OML 3002 and RSL 3003 TCP ports
<0025> control_if.c:911 CTRL at 127.0.0.1 4249
DB: Database initialized.
DB: Database prepared.
<0020> input/ipa.c:287 0.0.0.0:3002 accept()ed new link from 127.0.0.1:46113
<0005> abis_nm.c:497 BTS0 Get Attributes Response: reported unexpectedly long (3 bytes) feature vector - most likely it was compiled against newer BSC headers. Consider upgrading your BSC to later version.
<0005> abis_nm.c:507 BTS0 feature 'EGPRS' reported via OML does not match statically set feature: 0 != 1. Please fix.
<0005> abis_nm.c:507 BTS0 feature 'OML Alerts' reported via OML does not match statically set feature: 1 != 0. Please fix.
<0005> abis_nm.c:507 BTS0 feature 'CBCH' reported via OML does not match statically set feature: 1 != 0. Please fix.
<0005> abis_nm.c:577 BTS0: failed to parse SW-Config part of Get Attribute Response Info: Invalid argument
<0005> abis_nm.c:468 BTS0 Attribute Manufacturer Dependent State is unreported
<0005> abis_nm.c:577 BTS0: failed to parse SW-Config part of Get Attribute Response Info: Invalid argument
<0005> abis_nm.c:2757 (bts=0,trx=0) IPA RSL CONNECT IP=0.0.0.0 PORT=3003 STREAM=0x00
<0020> input/ipa.c:287 0.0.0.0:3003 accept()ed new link from 127.0.0.1:39653
<0004> bsc_init.c:312 bootstrapping RSL for BTS/TRX (0/0) on ARFCN 975 using MCC-MNC 001-01 LAC=1 CID=0 BSIC=63

root@space:~/.osmocom# osmo-bts-trx --debug DRSL:DOML:DLAPDM -r 99((*)) |
/ \ OsmoBTS
<0001> oml.c:1462 Initializing OML attribute definitions
<0017> control_if.c:911 CTRL at 127.0.0.1 4238
<0010> telnet_interface.c:104 Available via telnet 127.0.0.1 4241
<0012> input/ipaccess.c:901 enabling ipaccess BTS mode, OML connecting to 127.0.0.1:3002
<000b> trx_if.c:1174 phy0.0: Open transceiver
<0012> input/ipa.c:128 127.0.0.1:3002 connection done
<0012> input/ipaccess.c:724 received ID_GET for unit ID 1801/0/0
<0001> oml.c:220 (bts=0,trx=0): O&M Get Attributes [0], Manufacturer Dependent State is unsupported by TRX.
<0001> oml.c:641 OC=BTS INST=(00,ff,ff): Ignoring T2000 (150 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:641 OC=BTS INST=(00,ff,ff): Ignoring T2001 (180 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:641 OC=BTS INST=(00,ff,ff): Ignoring T2002 (180 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:641 OC=BTS INST=(00,ff,ff): Ignoring T2003 (1680 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:641 OC=BTS INST=(00,ff,ff): Ignoring T2004 (520 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:641 OC=BTS INST=(00,ff,ff): Ignoring T2005 (165 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:641 OC=BTS INST=(00,ff,ff): Ignoring T2006 (1680 ms) as sent by BSC due to suspected LAPDm bug!
<0012> input/ipa.c:128 127.0.0.1:3003 connection done
<0012> input/ipaccess.c:724 received ID_GET for unit ID 1801/0/0
<0009> sysinfo.c:199 Disabling GPRS Indicator in SI3 (No PCU connected)
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:610 Failed to send SI13 to PCU: -5
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<0009> pcu_sock.c:740 PCU socket not connected, dropping message
<000b> trx_if.c:185 phy0.0: No satisfactory response from transceiver(CMD POWEROFF)

1.png View 1.png 230 KB enceladusspace, 01/11/2020 05:23 PM
2.png View 2.png 99.7 KB enceladusspace, 01/11/2020 05:23 PM
111.png View 111.png 226 KB enceladusspace, 01/12/2020 09:40 AM
4008
4009
4010

History

#1 Updated by fixeria 8 months ago

  • Assignee deleted (fixeria)

Not sure why you assigned this ticket to me, but as far as I can see:

<000b> trx_if.c:185 phy0.0: No satisfactory response from transceiver(CMD POWEROFF)

you do not seem to have a transceiver running. Most likely, you also need to run OsmoTRX (if you have an SDR) or FakeTRX if you need a virtual RF-interface.

I use the configuration files with github, how do I gradually correct the settings and files?

We do not distribute configuration examples on GitHub. It is recommended to use those shipped together with the source code:

https://git.osmocom.org/osmo-bts/tree/doc/examples/trx
https://git.osmocom.org/osmo-trx/tree/doc/examples/

If you have more questions, please check out the user manuals first: http://ftp.osmocom.org/docs/latest/.

#2 Updated by enceladusspace 8 months ago

#3 Updated by enceladusspace 8 months ago

fixeria wrote:

Not sure why you assigned this ticket to me, but as far as I can see:

<000b> trx_if.c:185 phy0.0: No satisfactory response from transceiver(CMD POWEROFF)

you do not seem to have a transceiver running. Most likely, you also need to run OsmoTRX (if you have an SDR) or FakeTRX if you need a virtual RF-interface.

I use the configuration files with github, how do I gradually correct the settings and files?

We do not distribute configuration examples on GitHub. It is recommended to use those shipped together with the source code:

https://git.osmocom.org/osmo-bts/tree/doc/examples/trx
https://git.osmocom.org/osmo-trx/tree/doc/examples/

If you have more questions, please check out the user manuals first: http://ftp.osmocom.org/docs/latest/.

I did not appoint you, I left this field empty, I use Motorola C115, the TRX mode is running on it, the display shows TRX mode, and I see debugging information about the connection.

#4 Updated by fixeria 8 months ago

  • Project changed from OsmoTRX to OsmocomBB
  • Subject changed from OsmoBTS to CalypsoBTS: No satisfactory response from transceiver
  • Category changed from TRX Interface to CalypsoBTS

I use Motorola C115, the TRX mode is running on it, the display shows TRX mode [...]

The TRX firmware itself is not a transceiver, you still need to run additional software on your host. For more details, see:

https://osmocom.org/projects/baseband/wiki/CalypsoBTS

Keep in mind that Calypso PHY is not officially supported, and you're mostly on your own if something would not work. OsmoNiTB also has been abandoned years ago, but probably is still a good choice for beginners.

#5 Updated by fixeria 8 months ago

I did not appoint you, I left this field empty [...]

Huh, most likely I am automatically assigned to all tickets related to "TRX Interface" category ;)

#6 Updated by enceladusspace 8 months ago

fixeria wrote:

I use Motorola C115, the TRX mode is running on it, the display shows TRX mode [...]

The TRX firmware itself is not a transceiver, you still need to run additional software on your host. For more details, see:

https://osmocom.org/projects/baseband/wiki/CalypsoBTS

Keep in mind that Calypso PHY is not officially supported, and you're mostly on your own if something would not work. OsmoNiTB also has been abandoned years ago, but probably is still a good choice for beginners.

fixeria wrote:

I use Motorola C115, the TRX mode is running on it, the display shows TRX mode [...]

The TRX firmware itself is not a transceiver, you still need to run additional software on your host. For more details, see:

https://osmocom.org/projects/baseband/wiki/CalypsoBTS

Keep in mind that Calypso PHY is not officially supported, and you're mostly on your own if something would not work. OsmoNiTB also has been abandoned years ago, but probably is still a good choice for beginners.

How can I check if OsmoBTS is installed correctly and update it if necessary? Thank you for your help!

#7 Updated by fixeria 8 months ago

How can I check if OsmoBTS is installed correctly and update it if necessary?

What do you mean by "correctly"? Just build the recent version from git/master or use our binary packages:

https://osmocom.org/projects/cellular-infrastructure/wiki/Binary_Packages

You can check the version of any osmo-program this way: osmo-bts-trx --version.

#8 Updated by enceladusspace 8 months ago

4010

fixeria wrote:

How can I check if OsmoBTS is installed correctly and update it if necessary?

What do you mean by "correctly"? Just build the recent version from git/master or use our binary packages:

https://osmocom.org/projects/cellular-infrastructure/wiki/Binary_Packages

You can check the version of any osmo-program this way: osmo-bts-trx --version.

Having worked again, and using the configuration files that you pointed to, I stopped receiving the above errors, now I get messages that I need to change the specified parameters, but I can not find them in the osmo-bts.cfg and open-bsc files. cfg, where can I look for the options below in the screenshot?

#9 Updated by enceladusspace 8 months ago

OsmoBTS version 1.1.0.91-7544

#10 Updated by fixeria 6 months ago

Could you try to use the following branch of OsmocomBB?

https://git.osmocom.org/osmocom-bb/log/?h=fixeria/trx

I submitted some important fixes, and got it working on my side.

#11 Updated by fixeria about 2 months ago

  • Status changed from New to Resolved
  • Assignee set to fixeria

I updated the wiki page to recommend using fixeria/trx. Assuming the problem is fixed (no feedback during the last 5 months).

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)