Support #4482

New SIMtrace v2 board not doing anything

Added by HugoKriek 11 months ago. Updated 11 months ago.

Target version:
Start date:
Due date:
% Done:


Spec Reference:



I’m involved in a project with RSP SIMs where we need to get insight in the communication between modem and SIM.
So I bought a SIMtrace V2 board (from Sysmocom) and worked on my hardware setup based on: Ubuntu 18.04.4 LTS (GNU/Linux 5.3.0-45-generic x86_64).
Although I have some experience with Linux during my study, it is quite rusty, but as far as I’m aware my installation is completely up to the latest versions of everything.
I have followed the steps from the Wiki to build and install and that didn’t cause any errors, but in the end it doesn’t look right, there is no output.

I have tried to verify everything what I have done so far, but it doesn’t help, see below.

Firmware seems to be ok based on the response of DFU tool:
hugo@hugo-ubuntu:~$ sudo dfu-util --list
[sudo] wachtwoord voor hugo:
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Found Runtime: [1d50:60e3] ver=0002, devnum=12, cfg=1, intf=1, path="2-1", alt=0 , name="UNKNOWN", serial="51203120574a43503130313039313030"

Two USB ports are available, the first one connected to the board:
hugo@hugo-ubuntu:~/simtrace2/host/src$ sudo ./simtrace2-list
USB matches: 2
1d50:60e3 Addr=12, Path=2-1, Cfg=1, Intf=0, Alt=0: 255/1/0 (SIMtrace Sniffer)
1d50:60e3 Addr=12, Path=2-1, Cfg=2, Intf=0, Alt=0: 255/255/0 (

The sniffer shows no data what so ever:
hugo@hugo-ubuntu:~/simtrace2/host/src$ sudo ./simtrace2-sniff
simtrace2-sniff - Phone-SIM card communication sniffer
(C) 2010-2017 by Harald Welte <>
(C) 2018 by Kevin Redon <>

Using USB device 1d50:60e3 Addr=12, Path=2-1, Cfg=1, Intf=0, Alt=0: 255/1/0 (SIMtrace Sniffer)
Entering main loop

There is no output, requesting SIM data via Quectel dev board doesn’t change that. Also in Wireshark nothing is happening

Pressing the reset button on the board causes this error to appear:
BULK IN transfer error; rc=-4

I have used a Quectel development board with AT commands to see if any SIM related info is getting through, but is seems that there is no transparent communication with the SIM:
[2020-04-03 15:34:33:517_R:] AT+CPIN?
[2020-04-03 15:34:33:517_R:] +CME ERROR: SIM failure

In the home screen from Quectel IMSI and ICCID are not displayed (when I put the SIM straight in the dev board, it shows these values correctly).

So could anyone give me some hints what I’m doing wrong or what to verify please?

Kind regards,


#1 Updated by laforge 11 months ago

The setup look fine as per your description.

I'm wondering (sorry for the basic qustions):
  • did you re-start the modem after changing the SIM/
  • are you running the Ubuntu natively or in a VM? The latter is discourged due to timing implications.
  • did you ever try with any other modem/phone, just to see if it's specific to that?
  • what specific Quectel modem are you using (I have a variety here, and could try to reproduce)?
  • if you have one of the Osmocom-style 2.54mm USB uart cables available, it would be
    interesting to see what's happening on the serial port of the SIMtrace2 device
In general, the ideal sequence of starting a trace should be:
  • make all physical connections but don't power up modem yet
  • start the simtrace2-sniff (and optionally wireshark)
  • power up the modem as the last step


#2 Updated by HugoKriek 11 months ago

Hi Harald,

Thank you fot your prompt response.

The sequence of powering on makes a difference, I just did a quick test and had output from the sniff command (I thought I had done a reset before, but now I'm in doubt). However the query for IMSI and ICCID still fails, but with other error message.

To get back to your previous questions: I'm using the big Quectel development board (LTE & UMTS EVB kit) with a BG96 module attached to it. I also tried an Samsung S6 by the way, but I used a different chinees flat cable due to the form factor of the SIM, and I didn't check the pincompatibility (although I think it is hard to have a different layout on the cable). I'm running Ubuntu natively no VM involved. I don't have the UART cable available, but I can look into that if there is still a need for it.

First I'm going to take a look to the output and try to understand what the current status is. Thanks again!


Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)