Project

General

Profile

Feature #4511

Support a default APN for each EUA type

Added by keith 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
openggsn
Target version:
-
Start date:
04/25/2020
Due date:
% Done:

100%

Spec Reference:

Description

In a scenario where the UE configuration is unknown, we therefore do not know the APN configuration yet would like to support PS service regardless for all phones on the network.

Currently we can set a default-apn in the vty config, but that has to be a certain type;

Assuming a default config like in the example distributed with osmo-ggsn, we'll have three APNS, "internet", "inet6" and "inet46"
and the default is "internet" which has

type-support v4

If in the device config, the APN name is gprs.provider.name we will not match and we will use the default

The UE may request End User Address Type IPv4/IPv6 (according to the APN protocol field in the APN setup in the device).

Then we fail with:

DGGSN DEBUG PDP(262420000000222:5): Processing create PDP context request for APN 'gprs.provider.name' (ggsn.c:447)                                             
DGGSN ERROR PDP(262420000000222:5): APN doesn't support requested EUA / AF type (ggsn.c:591)
DGGSN INFO PDP(262420000000222:5): Deleting PDP context (ggsn.c:354)

History

#1 Updated by keith 9 months ago

  • Tracker changed from Bug to Feature
  • Category set to openggsn

#2 Updated by keith 9 months ago

  • Description updated (diff)

#3 Updated by keith 9 months ago

  • Description updated (diff)

#4 Updated by keith 9 months ago

I realise while working on this that each APN supports multiple types, so contrary to the Description, a default APN can be supported.

However, maybe the proposed solution patch has a use case, where one might want to use, (for example) a different IPv4 config on the v4 and v4v6 APNs while not knowing the names of the APNs ?

#5 Updated by keith 9 months ago

  • % Done changed from 0 to 80

#6 Updated by keith 9 months ago

  • Status changed from New to Closed
  • % Done changed from 80 to 100

This was misguided. The simple way to solve the problem is just add type-support v4v6 (and ipv6 configuration) to the default apn.

Closing.

I left the Work at http://git.osmocom.org/osmo-ggsn/commit/?h=keith/default-apns just in case anybody should come up with a need to configure separate default APNs (and their associated tun network devices) for IP v4/v6

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)