Project

General

Profile

Actions

Bug #4577

closed

centos packages pulled from the opensuse factory have unmet dependencies

Added by Hoernchen over 1 year ago. Updated 10 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
06/03/2020
Due date:
% Done:

0%

Spec Reference:

Description

In theory it should be possible to just install all packages from our centos feed, in practice:

[root@my-centos ~]# yum repo-pkgs network_osmocom_next install
Last metadata expiration check: 0:08:00 ago on Wed Jun  3 12:14:27 2020.
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides libgnutls-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides libjansson-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides libmicrohttpd-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides pkgconfig(libmicrohttpd) >= 0.9.53 needed by ulfius-devel-2.6.6-2.1.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

[root@my-centos ~]# yum repo-pkgs network_osmocom_next install --nobest
Last metadata expiration check: 0:07:19 ago on Wed Jun  3 12:14:27 2020.
Error: 
 Problem: conflicting requests
  - package ulfius-devel-2.6.6-2.1.aarch64 does not have a compatible architecture
  - nothing provides libgnutls-devel needed by ulfius-devel-2.6.6-2.1.aarch64
  - nothing provides libjansson-devel needed by ulfius-devel-2.6.6-2.1.aarch64
  - nothing provides libmicrohttpd-devel needed by ulfius-devel-2.6.6-2.1.aarch64
  - nothing provides pkgconfig(libmicrohttpd) >= 0.9.53 needed by ulfius-devel-2.6.6-2.1.aarch64
  - nothing provides libgnutls-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides libjansson-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides libmicrohttpd-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides pkgconfig(libmicrohttpd) >= 0.9.53 needed by ulfius-devel-2.6.6-2.1.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

[root@my-centos ~]# yum repo-pkgs network_osmocom_next install --skip-broken
Last metadata expiration check: 0:08:06 ago on Wed Jun  3 12:14:27 2020.
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides libgnutls-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides libjansson-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides libmicrohttpd-devel needed by ulfius-devel-2.6.6-2.1.x86_64
  - nothing provides pkgconfig(libmicrohttpd) >= 0.9.53 needed by ulfius-devel-2.6.6-2.1.x86_64
(try to add '--nobest' to use not only best candidate packages)

This is caused by pulling in opensuse factory packages without their deps in osmo-ci/scripts/osmocom-obs-link.sh

Actions #1

Updated by Hoernchen over 1 year ago

  • Project changed from 5 to Cellular Network Infrastructure
Actions #2

Updated by laforge 10 months ago

  • Assignee set to osmith
Actions #3

Updated by osmith 10 months ago

The only package that can't be installed from the repository is ulfius-devel.

From osmo-ci/scripts/repo-install-test/blacklist_centos8.txt:

# The ulfius package in network:osmocom:* is linked to the opensuse version,
# which has dependencies that exist under another name in centos
# (libgnutls-devel, libjansson-devel). Linking to the opensuse version has the
# advantage that we don't need to worry about updating the package. However,
# the dependency problem means that we can't simply install the package in
# centos. In OBS we work around this in the project config.
ulfius-devel

All other packages can be installed, and https://jenkins.osmocom.org/jenkins/job/Osmocom-repo-install-centos8/ verifies this daily.

Hoernchen: do we need to be able to install ulfius-devel too? If so, I could add dummy packages for libgnutls-devel -> gnutls-devel etc.

Related: https://build.opensuse.org/projects/network:osmocom:next/prjconf

Actions #4

Updated by Hoernchen 10 months ago

I don't know anything about ulfius or why it's required, but at the time it prevented easy installs of "all packages". Might be related to packages not really used/required on centos, i.e. remsim related stuff?

Actions #5

Updated by laforge 10 months ago

I think "ulfius-devel" is only required to build
  • osmo-cbc (relevant to our existing single CentOS user)
  • osmo-remsim (not important to our existing single CentOS user)

At runtime, no -devel packages should be required.

As long as we can install (and run) osmo-cbc binary from the feed, it is ok for now.

Actions #6

Updated by osmith 10 months ago

  • Status changed from New to Rejected

laforge wrote:

I think "ulfius-devel" is only required to build
  • osmo-cbc (relevant to our existing single CentOS user)
  • osmo-remsim (not important to our existing single CentOS user)

At runtime, no -devel packages should be required.

As long as we can install (and run) osmo-cbc binary from the feed, it is ok for now.

Okay, marking the issue as rejected then. We can change the status back if it should become relevant again.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)