Project

General

Profile

Bug #4802

TTCN3-centos-pcu-test-sns / ttcn3-pcu-tests-sns failing completely

Added by laforge about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
10/11/2020
Due date:
% Done:

100%

Spec Reference:

Description

The last three nights, the TTCN3-centos-pcu-tests are failing completely, both on CentOS and on Debian:

https://jenkins.osmocom.org/jenkins/view/TTCN3-centos/job/TTCN3-centos-pcu-test-sns/test_results_analyzer/

https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-pcu-test-sns/test_results_analyzer/

pespin / lynxis please figure out who will work on this. It looks like a very recent regression.

History

#1 Updated by fixeria about 2 months ago

MTC@DELL: Test case TC_sns_po_size_success finished. Verdict: fail reason: Received unexpected NS: { connId := 1, remName := "127.0.0.1", remPort := 22000, locName := "127.0.0.1", locPort := 23000, msg := { pDU_NS_Reset := { nsPduType := '02'O, causeNS := { iEI := '00'O, ext := '1'B, lengthIndicator := { length1 := 1 }, cause := '01'O }, nS_VCI := { iEI := '01'O, ext := '1'B, lengthIndicator := { length1 := 2 }, nS_VCI := '04D2'O }, nSEI_NS := { iEI := '04'O, ext := '1'B, lengthIndicator := { length1 := 2 }, nSEI := '04D2'O } } } }

#2 Updated by fixeria about 2 months ago

So we're getting unexpected RESET:

unexpected NS: {
    connId := 1,
    remName := "127.0.0.1",
    remPort := 22000,
    locName := "127.0.0.1",
    locPort := 23000,
    msg := {
        pDU_NS_Reset := {
            nsPduType := '02'O,
            causeNS := {
                iEI := '00'O,
                ext := '1'B,
                lengthIndicator := { length1 := 1 },
                cause := '01'O
            },
            nS_VCI := {
                iEI := '01'O,
                ext := '1'B,
                lengthIndicator := { length1 := 2 },
                nS_VCI := '04D2'O
            },
            nSEI_NS := {
                iEI := '04'O,
                ext := '1'B,
                lengthIndicator := { length1 := 2 },
                nSEI := '04D2'O
            }
        }
    }
}

vs expected {
    connId := ?,
    remName := ?,
    remPort := ?,
    locName := ?,
    locPort := ?,
    msg := {
        pDU_SNS_Size := {
            nsPduType := '12'O,
            nSEI_NS := {
                iEI := '04'O,
                ext := '1'B,
                lengthIndicator := { length1 := 2 },
                nSEI := '04D2'O
            },
            resetFlag := {
                iEI := '0A'O ("\n"),
                resetBIT := '1'B,
                spare := '0000000'B
            },
            maxNumberOfNSVCs := {
                iEI := '07'O ("\a"),
                maxNumberOfNSVCs := '0008'O
            },
            numberOfIP4_Endpoints := {
                iEI := '08'O ("\b"),
                numberOfIP_Endpoints := '0004'O
            },
            numberOfIP6_Endpoints := omit
        }
    }
}

#3 Updated by laforge about 2 months ago

The NS-RESET procedure is not applicable to a Gb interface that uses IP-SNS. So either there's a b ug in the configuration, or it's a bug in the NS2 code. lynxis, feel free to chime in. Thanks!

#4 Updated by lynxis about 2 months ago

strange. I've ran the SNS test cases on debian and they succeed.

#5 Updated by fixeria about 1 month ago

Kind reminder: TTCN3-centos-pcu-test-sns [1] is ok, but ttcn3-pcu-test-sns-latest [2] still fails (15 builds in a row, since 581).

[1] https://jenkins.osmocom.org/jenkins/view/TTCN3-centos/job/TTCN3-centos-pcu-test-sns/
[2] https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-pcu-test-sns-latest/

#6 Updated by lynxis about 1 month ago

The TTCN3 testcase 1c1u is doing SNS Config with
pcu 23000 <-> 23001 sgsn
23000 <-> 23002 sgsn

But now the ttcn is sending a NS Alive for 23000 <> 23000 which isn't configured. The PCU answer with invalid status.

#7 Updated by lynxis about 1 month ago

pespin did you created a release already with the ns2 code?

#8 Updated by lynxis about 1 month ago

  • Status changed from New to In Progress
  • Assignee changed from pespin to lynxis

#9 Updated by lynxis about 1 month ago

  • Status changed from In Progress to Resolved

ttcn3-pcu-tests-sns recoved (still some smaller issues, both debian/centos)

ttcn3-pcu-tests-sns-latest still failing, which is correct!
The ttcn test cases got improved. It's now forbidden to attach the cell id on signalling BVC Resets (as the spec says so).

#10 Updated by lynxis about 1 month ago

  • % Done changed from 0 to 100

#11 Updated by pespin about 1 month ago

lynxis wrote:

pespin did you created a release already with the ns2 code?

No

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)