Project

General

Profile

Actions

Bug #4859

closed

DUG20 + RUS 01 = Admin: Locked, Power off

Added by keith 12 months ago. Updated 23 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/10/2020
Due date:
% Done:

0%

Spec Reference:

Description

First attempt at bring up an RBS system, and capturing logs and debug info...


Files

osmo-bsc.dug20.rus01.log osmo-bsc.dug20.rus01.log 276 KB keith, 11/10/2020 09:37 PM
e1.pcap e1.pcap 19.6 KB keith, 11/10/2020 09:38 PM
system.conf system.conf 348 Bytes keith, 11/10/2020 09:38 PM
osmo-bsc.dug20-rus01-4trx.cfg osmo-bsc.dug20-rus01-4trx.cfg 4.93 KB keith, 11/10/2020 09:39 PM
wireshark-om2k.png View wireshark-om2k.png 49.3 KB laforge, 11/10/2020 10:27 PM
RUS 01 0_log_1.txt RUS 01 0_log_1.txt 55.8 KB keith, 11/16/2020 09:10 PM
DUG 0_log_1.txt DUG 0_log_1.txt 174 KB keith, 11/16/2020 09:10 PM
rus01-e1-TF.pcap rus01-e1-TF.pcap 516 KB keith, 11/21/2020 01:13 AM
Actions #1

Updated by laforge 12 months ago

For some strange reason current wireshark seems to be completely unable to decode the OM2000, I don't have the time right now to start investigating that, sorry. Without a proper decode it's hard to know what's happening here.

Actions #2

Updated by laforge 12 months ago

Despite having the gsm_abis_oml dialect set to "Ericsson OM2000", I get only "data" as decode:

Actions #3

Updated by tnt 12 months ago

Weird, decode works for me.

What I see is the TF Configuration Request and TF Configuration Request Ack, but then nothing from the TF after that.
So to me, that indicates either an E1 clock out of range, or the internal OCXO is still warming up.

Actions #4

Updated by laforge 12 months ago

I just rebuilt wireshark master (33e63d19e5496c151bad69f65cdbc7cba2b4c211), and it does still exhibit the problem.

I also see the problem with the oldes build I have currently installed: v3.3.0rc0-1701-g4bea0e7c2ebf which I built on July 25th.

Actions #5

Updated by laforge 12 months ago

doh!

for some strange reason I had gsm_abis_om2000 in the ~/.wireshark/disabled_protos list. No idea how that happened...

Actions #6

Updated by keith 12 months ago

Adding RUS and DUG logs retrieved from OMT after power on and 1 attempt to run osmo-bsc.

Actions #7

Updated by keith 11 months ago

Adding a PCAP after we get a TF Configuration Result.

would it be that the DUG does not like one of our SI5 messages?

Actions #8

Updated by laforge 11 months ago

On Sat, Nov 21, 2020 at 01:15:06AM +0000, keith [REDMINE] wrote:

would it be that the DUG does not like one of our SI5 messages?

yes, that is very likely if you send unsupported features in the SI, or if you
send SI messages that are entirely unsupported. Howver, that shouldn't matter
in terms of phones seeing the BTS at all, and getting location updates etc.
going.

Actions #9

Updated by keith 11 months ago

Ok Thanks, I should clarify there is still no RF transmission from the unit and no channels listed as active in osmo-bsc.

Things do not advance after this last SACCH FILLing error.

Actions #10

Updated by keith 23 days ago

  • Status changed from New to Closed

Closing as: of little value apart from some documentation of first experiences with the RBS units.

Mostly it was due to E1 clock out of range, E1 clock was from a PCI card, using the iceE1 or a GPS unit fixed waiting forever at TF Configuration Request Ack

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)