Project

General

Profile

Bug #4870

BTS features parsed too late

Added by lynxis 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
11/27/2020
Due date:
% Done:

100%

Spec Reference:

Description

The BSC requests the BTS features after it has used to decide if the BTS can be used for IPv6.

oml_too_late.pcapng oml_too_late.pcapng 374 KB lynxis, 11/28/2020 01:19 AM

Associated revisions

Revision ee9f02f2 (diff)
Added by pespin 5 months ago

Introduce NM GPRS NSE FSM

Related: OS#4870
Change-Id: I91a5f40324d5373eac885032295690cec97214a6

Revision aab54b44 (diff)
Added by pespin 5 months ago

Introduce NM GPRS CELL FSM

Related: OS#4870
Change-Id: I074f4496aa153b5f84e6ce85f413754efe64d831

Revision d74bb1e3 (diff)
Added by lynxis 5 months ago

Introduce NM GPRS NSVC FSM

Related: OS#4870
Change-Id: I381472532c2622a8dba7c81ae00ea873c2e58ae1

Revision dd6af77e (diff)
Added by pespin 5 months ago

abis_nm: Simplify param passing to abis_nm_rx_get_attr_resp()

There's no real need to retrieve the trx before passing it to the
function, we can do that in the function itself and hence also simplify
the function itself.

Related: OS#4870
Change-Id: I7181510c5021ff2712c09ebc6ec8b13fdd8e8dc2

Revision 10364c89 (diff)
Added by pespin 5 months ago

Handle BTS/BBTRANSC Get Attributes (Ack) in NM FSMs

Before this patch, Get Attributes was sent quicklyafter the OML link
became up, even if the BTS/BB_TRANSC objects were still powered off,
which is wrong since attributes should only be available after the
objects transition out of the Power off state.

Furthermore, information about get attr response already received will
be required in future patches to delay NSVC setting.

Related: OS#4870
Change-Id: I8ec39c7e1f956ffce9aecd58a5590c43200ba086

Revision 44a0e0fc (diff)
Added by Pau Espin Pedrol 5 months ago

oml: Delay configuring NSVC until BTS features are negotiated

This is needed in order to to proper feature support verification for
IPv6 when configuring the NSVC.
Before this patch, there could be a race condition where NSVC FSM
checked for BTS feature BTS_FEAT_IPV6_NSVC before it was negotiated
through BTS Get Attributes (Ack).

Fixes: OS#4870
Change-Id: I7c207eee0e331995ae04acec014fbd13d4d16280

History

#1 Updated by lynxis 5 months ago

  • Subject changed from BTS features are requested too late to BTS features requested too late

#2 Updated by lynxis 5 months ago

The BSC parse the BTS features which are requested via "Get Attribute" too late to allow the NSVC MO to check for the IPv6 feature.
The BSC already generated the NSVC MO Set Attribute packet when it receives the "State Event Report" for the NSVC MO which is before the feature response is parsed.

So in general I would expect to parse the feature message before triggering any MO object response.

#3 Updated by lynxis 5 months ago

#4 Updated by lynxis 5 months ago

When the BTS is connected a second time, the features from the first time are still present. So reconnecting a BTS could be considered as dirty workaround :).

#5 Updated by laforge 5 months ago

  • Priority changed from Normal to High

#6 Updated by pespin 5 months ago

The problem is most probably that I didn't work on the FSMs for the gprs-related MO, such as NSVC, so those are still handled the old way by pushing everything quite quickly.

So in order to solve this iiuc we need to:
  • Implement FSM for misisng gprs-related MOs,
  • In the BSC, Delay set up of NSVC MO until we received BTS Get Attributes Response.

#7 Updated by lynxis 5 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 70

Since my workaround doesn't work (thanks race conditions!). I've created a NSVC fsm and a simple feature negotiating flag.

pespin can you review it and test it against a nanobts?

https://gerrit.osmocom.org/c/osmo-bsc/+/21451
https://gerrit.osmocom.org/c/osmo-bsc/+/21452

#8 Updated by pespin 5 months ago

  • % Done changed from 70 to 90

I reworked lynxis patches on top of mine adding FSMs for all GPRS-related MOs.

Issue should be fixed by these:
remote: https://gerrit.osmocom.org/c/osmo-bsc/+/21452 Introduce NM GPRS NSVC FSM
remote: https://gerrit.osmocom.org/c/osmo-bsc/+/21501 abis_nm: Simplify param passing to abis_nm_rx_get_attr_resp()
remote: https://gerrit.osmocom.org/c/osmo-bsc/+/21502 Handle BTS/BBTRANSC Get Attributes (Ack) in NM FSMs
remote: https://gerrit.osmocom.org/c/osmo-bsc/+/21538 Fix typo in function nanobts_attr_nsvc_get [NEW]
remote: https://gerrit.osmocom.org/c/osmo-bsc/+/21451 oml: Delay configuring NSVC until BTS features are negotiated

#9 Updated by pespin 5 months ago

  • Assignee changed from pespin to lynxis

All patches ahve been merged except the last one. Reassigning to lynxis so he tests everything's fine with that one since he can reproduce the issue.

Once merged and issue is for sure fixed, feel free to close the ticket.

#10 Updated by pespin 4 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

AFAIC lynxis already tested this and it's working fine, so closing the ticket.

#11 Updated by lynxis 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)