Bug #4918

icE1usb bootloader suddenly 'gone" ?

Added by laforge 5 months ago. Updated 5 months ago.

Target version:
Start date:
Due date:
% Done:


Spec Reference:


This is the icE1usb unit I've been using for all my E1 related development during the past week or so. It has serial number "dc697407e7881531"

I have been using DFU extensively to flash the firmware (-a1). I've not flashed any gateware during the past weeks, nor have I ever tried to install the bootlodaer itself. That should be in pristine condition from when this unit arrived (the first prototpye in the 'real' enclosure, before the production run).

Until yesterday, I was able to go into DFU mode both by pressing the button as well as via the 'dfu-util -e' switch.

Today, the first time I tried to switch via 'dfu-util -e', it failed to re-enumerate. Also, it ddoesn't enumerate at all when pressing the button at power-up. There is also no single character printed to the serial console when booting with button pressed.

I can still use it with the last firmware I flashed via DFU, but I can no longer upgrade it.

I'll keep the device as-is for now and not try any further operations that might modify the internal state.

Any ide what might have happened here?


#1 Updated by laforge 5 months ago

I've disconnected E1, GPS and also the serial console to see if it might be any external influence, no change.

#2 Updated by laforge 5 months ago

  • Priority changed from Normal to Low

A few minutes later, it suddenly all works again. not sure what is going on here :(

#3 Updated by tnt 5 months ago

If this happens gain, some things to look at :

- State of the RGB LED
- State of the 'DONE' LED (you can see it through the GPIO connector gap, if there is a blue light inside)

Something to keep in mind as well is that the bootloader loaded on that particular unit is probably not the same version as was loaded on the production units.

If you look at the `no2bootloader` repo, it was created a few days before I flashed all the production units, that's because I did a lot of cleanup/improvement work on it right before flashing all of those. And since the pre-prod unit is from like a month before, it would have an older bootloader and stub code.

#4 Updated by laforge 5 months ago

  • Status changed from New to Rejected

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)