Project

General

Profile

Feature #4971

OsmoCC Socket Documentation

Added by foxrf about 1 month ago. Updated 1 day ago.

Status:
New
Priority:
Immediate
Assignee:
Target version:
-
Start date:
01/22/2021
Due date:
% Done:

0%

Spec Reference:

Description

It appears that the MNCC socket has been replaced with OSMOCC which does not appear to have ANY documentation around how you are actually supposed to configure call routing with this thing. More specially the osmo-cc-router package attempts to call a bash script "routing.sh" for which there is no sample or documentation going over the syntax. Please add full documentation on how this bash script is supposed to route calls and or provide a detailed example script.

Screenshot from 2021-01-22 16-20-23.png View Screenshot from 2021-01-22 16-20-23.png 175 KB foxrf, 01/22/2021 10:27 PM
IMG_3821.jpg View IMG_3821.jpg 928 KB atmega, 02/12/2021 11:07 AM
4473
4503

History

#1 Updated by laforge about 1 month ago

  • Assignee set to jolly

#2 Updated by laforge about 1 month ago

I've assigned this to jolly, as he's really the only one (AFAICT) working on osmocom-analog.

As for OsmoCC, there had been an early "concept paper" that jolly shared among the Osmocom developers, but I'm not sure how accurate it still is, and whether he intended it to be publicly distributed.

#3 Updated by atmega 16 days ago

Hey, did you managed to do anyprogress? What OSMO-CC should connect to ?

#4 Updated by atmega 16 days ago

4503

I am stuck at socket failed ;-(

#5 Updated by foxrf 15 days ago

On 2021-02-12 05:08, atmega [REDMINE] wrote:

Issue #4971 has been updated by atmega.

File IMG_3821.jpg added

I am stuck at socket failed ;-(

#6 Updated by aldude999 1 day ago

It looks like the routing script needs to echo commands based on the calling number/called number on what to do on what call. Taking a look at call.c under the routing_receive_stdout() function seems to show a list of possible commands. I was able to get it to respond to my calls with the "call cannot be completed as dialed" response by placing the following in the routing.sh script:

#!/bin/sh
echo "call interface :"

Then set the permissions on the routing script to 775. I'll have to play with some of the endpoint software to see if it gets me any further. It looks like more complex scripts could be built by comparing the arguments osmo-cc-router sends the scripts, it looks like it sends the caller/called number as arguments.

#7 Updated by aldude999 1 day ago

So after fiddling around with the software a bit more, I managed to get a call going through SIP, you have to compile osmo-cc-sip-endpoint, osmo-cc-router isn't actually needed at all. I set up an Asterisk server, but any SIP server should work. I made an account for the cell phone using it's phone number as the extension.

One thing I did notice was that if you tried to make a call from a sip client to your analog phone, something along the way drops the phone number you want to ring. Here's the command I ran to get the sip endpoint working:

osmo-cc-sip-endpoint -r [SIP_SERVER_IP] -l [OSMOCOM-ANALOG_IP] -A [PHONENUMBER] [SIP_PASSWORD] [DOMAIN/IP] --register [PHONENUMBER]@[DOMAIN/IP] --cc 'screen-called-in "" "[PHONENUMBER]"'

The screen-called-in replaces the weird null phone number into the actual phone you want to ring.

Hope this helps out a bit!

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)