Project

General

Profile

Actions

Bug #5037

closed

rbs2000 Remote Transcoder Failure

Added by keith 10 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
-
Start date:
02/20/2021
Due date:
% Done:

0%

Spec Reference:

Description

It seems possible that something broke something relatively recently.

I say that because I had a working system up until doing an apt upgrade with osmocom nightly.

With current nightly, all calls fail with this distinctive error in osmo-bsc:

abis_rsl.c:982 lchan(0-0-7-TCH_F-0)[0x55753645df50]{ESTABLISHED}: (type=TCH_F) CONNECTION FAIL (cause=Remote Transcoder Failure [ 28 ])

I connected the DUG/RUS to an older system and the error did not occur.

I tried to a small extent dissecting osmo-bsc but I couldn't find it. Which makes me think whatever broke is maybe not in osmo-bsc
I copied all the osmo- binaries from the working system and still get the error!!

So ..Something in libosmocore/abis? Anyway, I'm exhausted with this and need to take a break, so Sorry it's not a better bug report.

See packet number 582 in the pcap.


Files

pcap.pcap pcap.pcap 39.7 KB keith, 02/20/2021 01:59 AM
Actions #1

Updated by keith 10 months ago

  • Description updated (diff)
Actions #2

Updated by keith 10 months ago

On the old machine that worked;

I started upgrading packages one by one, restarting osmo-bsc, osmo-msc and osmo-mgw each time.

I did that for the following individually, and calls kept working.

apt install osmo-mgw

same apt install for:
osmo-msc
osmo-bsc
libosmo-sigtran5
osmo-stp
libosmocore16
libosmoabis9
libosmotrau2

Then unfortunately I let frustration get the better of my patience, and just went ahead with apt upgrade.
This system is now also giving:


20210219210208350 DCHAN ERROR lchan(0-0-7-TCH_F-0)[0x5568baed4740]{WAIT_BEFORE_RF_RELEASE}: (type=TCH_F) CONNECTION FAIL (cause=Remote Transcoder Failure [ 28 ]) (abis_rsl.c:982)

At least it's confirmed that something in the upgrade broke it:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-4.19.0-14-amd64 linux-headers-4.19.0-14-common linux-image-4.19.0-14-amd64
The following packages will be upgraded:
  base-files bind9-host ca-certificates dnsmasq dnsmasq-base file grub-common grub-pc grub-pc-bin grub2-common iproute2 libapache2-mod-php7.3 libasn1c1 libbind9-161
  libcairo2 libdns-export1104 libdns1104 libfdt1 libgnutls-dane0 libgnutls-openssl27 libgnutls28-dev libgnutls30 libgnutlsxx28 libisc-export1100 libisc1100 libisccc161
  libisccfg163 libldap-2.4-2 libldap-common liblwres161 libmagic-mgc libmagic1 libnode-dev libnode64 libnss-systemd libosmo-e1d-dev libosmo-e1d0 libosmo-gsup-client0
  libosmo-mslookup0 libosmo-netif-dev libosmo-ranap3 libosmo-sccp-dev libosmocore-dev libosmocore-utils libosmonetif8 libosmotrau2 libp11-kit-dev libp11-kit0 libpam-systemd
  libpq5 libsmpp1 libssl-dev libssl1.1 libsystemd0 libudev1 libzstd1 linux-compiler-gcc-8-x86 linux-headers-amd64 linux-image-amd64 linux-kbuild-4.19 linux-libc-dev
  node-ini node-y18n nodejs nodejs-doc openssl osmo-e1d osmo-hlr osmo-sip-connector php7.3 php7.3-cli php7.3-common php7.3-curl php7.3-gd php7.3-intl php7.3-json
  php7.3-mbstring php7.3-opcache php7.3-pgsql php7.3-readline php7.3-xml postgresql-9.6 postgresql-client-9.6 postgresql-client-common postgresql-common
  postgresql-contrib-9.6 python-apt-common python3-apt sudo systemd systemd-sysv tzdata udev unzip
94 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 107 MB of archives.

Actions #3

Updated by laforge 10 months ago

remote transcoder failure is something the BTS sends if it cannot establish the TRAU
link over Abis to osmo-mgw.

So either osmo-mgw is not running, not configured correctly, or osmo-mgw or libosmo-abis
somehow have a regression.

libosmo-abis didn't have many commits recently, neither did osmo-mgw. I would
guess you could try reverting those:

Regards,
Harald

Actions #4

Updated by keith 10 months ago

  • Status changed from New to In Progress
  • Assignee set to keith
  • Priority changed from Normal to Low

I'm a bit at a loss to explain this.

No config files changed, but I uninstalled all packages and built everything from source, which worked, then I reinstalled all packages and that also works.

I notice there is still a: CONNECTION FAIL (cause=Remote Transcoder Failure [ 28 ])

error in the osmo-bsc log when every call ends, I must have been mis-interpreting this immediate call termination (caused by something else) as being related to this error in the log. Or maybe something else changed in the last 24 hours..

I still have one broken system - I might go back and check what is happening there, but I will probably just close this as invalid.

Actions #5

Updated by laforge 10 months ago

On Mon, Feb 22, 2021 at 01:38:43AM +0000, keith [REDMINE] wrote:

I notice there is still a: CONNECTION FAIL (cause=Remote Transcoder Failure [ 28 ])
error in the osmo-bsc log when every call ends,

I would guess this is likely just an artefact during shutdown, as we
probably shut down the MGW side slightly before shutting down the
channel on the BTS side. If the call works fine before the message, I
would simply ignore it.

Actions #6

Updated by keith 2 months ago

  • Status changed from In Progress to Closed

Closing, this hasn't been reproduced.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)