Project

General

Profile

Bug #5059

Calls between C-Netz mobiles using -x option do not connect

Added by mstamm 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/05/2021
Due date:
% Done:

100%

Spec Reference:

Description

I have set up osmocom-analog with a LimeSDR and using the --SDRSoapy option, with three channels: OgK 131, and SpK 135 and 137. I am using the -x command line option to activate the internal routing. There are two mobile phones registered with osmocom-analog, one AEG Telecar 450 CD (no. 5218902), and one Nokia C-130 (no. 2903180). Both phones register successfully.

In this setup, a call from one C-Netz mobile to another registered at the same time is not signalled at the target mobile and does not connect. Instead, the calling mobile is connected to a queue waiting music. I have tried dialling only the mobile numbers 5218902 and 2903180 respectively and prefixing them with 0161, the former cellular routing code for C-Netz. The same effect occurs if I randomly dial a number the mobile. The call is connected to the waiting music.

I have tried finding clues as to what could cause this issue in the verbose console output but could not locate any information that would be useful to me, so am hoping a more experienced user can point me to the cause of the issue. I do not want to exclude the possibility that there is some fundamental issue I am missing.

There is one issue perhaps related: I cannot use a locally connected headset as a sound device to place a call from the console to a mobile. Compiling osmocom-analog from the eversberg.eu repository, ALSA support was shown as active, and alsamixer can configure the headset (a Jabra USB headset), and I can use the headset for all other applications. However, when I start cnetz with the associated parameter, I get the message that sound support is not compiled in. I did not investigate this issue further as my first goal was and is mobile-to-mobile calls, and eventually mobile-to-sip and sip-to-mobile calls, but perhaps this may be a related issue or point to a common cause? I greatly appreciate any help.

mstamm-cnetz.txt mstamm-cnetz.txt 254 KB console output for cnetz using option -x and call attempts between mobiles mstamm, 03/05/2021 12:19 PM

History

#1 Updated by aldude999 2 months ago

I cannot seem to get -x working either, using the AMPS software. Seems to be a bug.

#2 Updated by mstamm 2 months ago

aldude999 wrote:

I cannot seem to get -x working either, using the AMPS software. Seems to be a bug.

Perhaps there are additional components needed? I don't believe this is the case as no such dependencies are mentioned anywhere in the documentation. Are the issues you are experiencing similar to mine?

#3 Updated by aldude999 2 months ago

mstamm wrote:

aldude999 wrote:

I cannot seem to get -x working either, using the AMPS software. Seems to be a bug.

Perhaps there are additional components needed? I don't believe this is the case as no such dependencies are mentioned anywhere in the documentation. Are the issues you are experiencing similar to mine?

Same issue, it just plays the default music. It doesn't seem to cause any issues with the osmocc-sock capability though.

#4 Updated by jolly 2 months ago

Just pushed a fix to master branch. It should work now.

#5 Updated by atmega 2 months ago

any chance to hear in my subject from you Jolly ? Greetings from Poland :)

#6 Updated by mstamm 2 months ago

jolly wrote:

Just pushed a fix to master branch. It should work now.

I'm extremely happy to confirm it works. Mobiles I have tested are AEG Telecar CD 452, Nokia C-130, Philips MiniPorty. Signalling works in both directions, and calls connect. A big thank-you to jolly for this fast fix!

#7 Updated by atmega 2 months ago

mstamm wrote:

jolly wrote:

Just pushed a fix to master branch. It should work now.

I'm extremely happy to confirm it works. Mobiles I have tested are AEG Telecar CD 452, Nokia C-130, Philips MiniPorty. Signalling works in both directions, and calls connect. A big thank-you to jolly for this fast fix!

I have tried on NMT - it sounds like when are two channesl and two cards selected :

nmt -k 1 -k 4 -a hw:1,0 -a hw:2,0 -T CC/TC -T CC/TC -0 1 -0 1 -Y pl,1 -x

then in second card are strange sounds - from example here - i could hear strange sound in channel 4 in my case, but when I launch one channel :

nmt -k 1 -Y pl,2 -a hw:1,0 or nmt -k 1 -Y pl,2 -a hw:2,0 the transmitting channels are clear ... any reason for that when I enable both channels with -x command ?

#8 Updated by laforge 2 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90

FYI, we just created the osmocom-analog mailinglist for general discussion unrelated to bugs/issues here: https://lists.osmocom.org/mailman/listinfo/osmocom-analog

#9 Updated by mstamm 2 months ago

For the record:

There is one issue perhaps related: I cannot use a locally connected headset as a sound device to place a call from the console to a mobile. Compiling osmocom-analog from the eversberg.eu repository, ALSA support was shown as active, and alsamixer can configure the headset (a Jabra USB headset), and I can use the headset for all other applications. However, when I start cnetz with the associated parameter, I get the message that sound support is not compiled in. I did not investigate this issue further as my first goal was and is mobile-to-mobile calls, and eventually mobile-to-sip and sip-to-mobile calls, but perhaps this may be a related issue or point to a common cause? I greatly appreciate any help.

is also resolved but was quite unrelated. It turns out I had to run make clean, then make, as I had already previously compiled osmocom-analog without sound support, and after a make clean and make, the sound adapter also works using the -c option.

#10 Updated by laforge 2 months ago

aldude999, atmega, mstamm I also gave all of you some more permissions here, so you can now create/edit wiki pages, if you want to share some of your findings on how to get osmocom-analog working, or the like.

#11 Updated by mstamm 2 months ago

laforge wrote:

aldude999, atmega, mstamm I also gave all of you some more permissions here, so you can now create/edit wiki pages, if you want to share some of your findings on how to get osmocom-analog working, or the like.

laforge - Cool, thank you. Actually, creating one or more Wiki pages is exactly what I had in mind. When it comes to LimeSDR operations and specifically osmocom-analog, I feel like I'm the new kid on the block. I have been playing with openSUSE Tumbleweed occasionally with a view to perhaps eventually replacing my Windows-based infrastructure with Linux, and I had to learn using LimeSDR and setting up osmocom-analog from scratch (including some learning on using alsa, compiling, identifying missing components, differentiating between distribution-based components and myriadrf-provided ones, resolving conflicts, etc etc) since I got my hardware on 01 March. I found the documentation provided by jolly very helpful, and believe a collection of "HOWTO" recipes in the Wiki will help others. Now that I have mobile-to-mobile calls and console-to-mobile calls sorted out, the next agenda item will be getting the osmo-cc-sip-endpoint to work, and then later calls between C-Netz and AMPS and/or TACS mobiles. Undoubtedly, this will take me along another steep learning curve, and I'll be happy to share the results.

#12 Updated by mstamm about 2 months ago

  • Status changed from In Progress to Resolved

The issue has been identified and remedied, so I'm closing this issue.

#13 Updated by mstamm about 2 months ago

  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)