Bug #5120


rtlsdr_demod_write_reg failed with -9

Added by desolve almost 3 years ago. Updated almost 3 years ago.

Target version:
Start date:
Due date:
% Done:


Spec Reference:


I'm on Arch Linux 64 bit, latest updates installed. Software versions:
  • gqrx 2.14.4
  • gnuradio
  • gnuradio-osmosdr 0.2.3
  • rtl-sdr 0.8.0
    I've migrated this install from Asus VivoMini VC65 / Intel i3-6100T setup to the Asus PRIME B550-PLUS / Ryzen 3900XT. I've noticed that when I set frequency in GQRX I observe errors in console log:
    rtlsdr_demod_write_reg failed with -9
    r82xx_write_arr: i2c wr failed=-9 reg=17 len=1

    and so on. As a result GQRX doesn't set frequency correctly, only on occasional success. I've even filed a bug ( on their GitHub but then I've realized that the problem is with rtlsdr library itself. I've tried different RTL SDR dongles (V3 and versions from Aliexpress) but with the same result. I've tried to connect dongle directly to the USB ports, have tried different ports (2.0 and 3.0, back and front) - but with no positive result. I've even tried to mangle with UEFI USB settings such as IOMMU, XHCI hand-off and so on - and with no luck. At the same time Airspy R2 works just well with this setup so it seems like a problem related to the way how librtlsdr communicates with RTLSDR dongles.

It would be very helpful to get some advice.

Actions #1

Updated by desolve almost 3 years ago

It used to work on VivoMini setup and doesn't work on current. At the same time other USB devices (flash drives, keyboards, mices, Airspy R2 and so on) work well. So may be it's related to the intrinsic USB code which librtlsdr uses


Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)