Project

General

Profile

Bug #5121

This PHY does not support lchan TSC 3 != BSIC-TSC 7

Added by keith 28 days ago. Updated 28 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
osmo-bts-virtual
Target version:
-
Start date:
04/18/2021
Due date:
% Done:

100%

Spec Reference:

Description

This PHY does not support lchan TSC 3 != BSIC-TSC 7
seen in logs with osmo-bts-virtual/virt_phy/layer23-mobile setup.

osmo-bsc Network + BTS config:

network
 network country code 262
 mobile network code 42
 encryption a5 1
 neci 1
 paging any use tch 0
 handover 0
 handover algorithm 1
 handover1 window rxlev averaging 10
 handover1 window rxqual averaging 1
 handover1 window rxlev neighbor averaging 10
 handover1 power budget interval 6
 handover1 power budget hysteresis 3
 handover1 maximum distance 9999
 meas-feed destination 127.0.0.1 8888
[snip.snip]
 bts 1
  type sysmobts
  description VirtualBTS
  band 1800
  cell_identity 0
  location_area_code 101
  base_station_id_code 63
  ms max power 5
  cell reselection hysteresis 4
  rxlev access min 0
  radio-link-timeout 32
  channel allocator ascending
  rach tx integer 9
  rach max transmission 7
  channel-description attach 1
  channel-description bs-pa-mfrms 5
  channel-description bs-ag-blks-res 1
  no access-control-class-ramping
  early-classmark-sending forbidden
  early-classmark-sending-3g allowed
  ipa unit-id 2000 15
  oml ipa stream-id 255 line 0
  neighbor-list mode automatic
  codec-support fr amr
  amr [snip..snip]
  gprs mode none
  no force-combined-si
  trx 0
   rf_locked 0
   arfcn 600
   nominal power 23
   max_power_red 0
   rsl e1 tei 0
   timeslot 0
    phys_chan_config CCCH
    hopping enabled 0
   timeslot 1
    phys_chan_config SDCCH8
    hopping enabled 0
   timeslot 2
    phys_chan_config TCH/H
    hopping enabled 0
   timeslot 3
    phys_chan_config TCH/H
    hopping enabled 0
   timeslot 4
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 5
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 6
    phys_chan_config TCH/F
    hopping enabled 0
   timeslot 7
    phys_chan_config PDCH
    hopping enabled 0

osmo-bts config:

e1_input
 e1_line 0 driver ipa
 e1_line 0 port 0
 no e1_line 0 keepalive
phy 0
 instance 0
bts 0
 band 1800
 ipa unit-id 2000 15
 oml remote-ip 172.16.0.1
 trx 0
  phy 0 instance 0

osmo-bts.log osmo-bts.log 43.5 KB keith, 04/18/2021 09:37 PM
BSIC_TSC.pcapng BSIC_TSC.pcapng 2.75 KB keith, 04/18/2021 09:38 PM

Associated revisions

Revision 5ac44561 (diff)
Added by fixeria 28 days ago

l1sap: fix incorrect pointer cast in l1sap_chan_act()

In [1] I introduced a regression, so osmo-bts started to complain:

This PHY does not support lchan TSC 3 != BSIC-TSC 7

on channel activation, despite the TSC in RSL_IE_CHAN_IDENT was 7.

The problem is that this statement:

cd = (const struct gsm48_chan_desc *) TLVP_VAL(tp, RSL_IE_CHAN_IDENT) + 1;

is basically equivalent to:

cd = ((const struct gsm48_chan_desc *) TLVP_VAL(tp, RSL_IE_CHAN_IDENT)) + 1;

so we actually shift the pointer by sizeof(struct gsm48_chan_desc)
and skip 3 octets instead of just one (IEI octet). Fix this.

Change-Id: Ic3a81396b60577e03c541d32839d07dc6d45c838
Fixes: [1] Id100f4c56fd5c1adad5d925d97240bed82981b9b
Fixes: OS#5121

History

#1 Updated by keith 28 days ago

  • Assignee set to fixeria

#2 Updated by fixeria 28 days ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

Thank you very much for reporting!

I found the problem while looking at the code:

https://gerrit.osmocom.org/c/osmo-bts/+/23787 l1sap: fix incorrect pointer cast in l1sap_chan_act()

#3 Updated by fixeria 28 days ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)