Project

General

Profile

Bug #5187

osmo-remsim packages in -latest missing systemd initscripts

Added by roh 4 months ago. Updated about 1 month ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
06/20/2021
Due date:
% Done:

70%

Spec Reference:

Description

the packages in the -latest feeds for (atleast) debian 10 are missing systemd scripts and config snippets.

the packages in -nightly have atleast systemd scripts, but no config snippets.
making sure /etc/osmocom is there and atleast a stub bankd_pcsc_slots.csv would help a lot.
change the default ip for the server-ip in bankd defaults to 127.0.0.1 instead of a 10.9.x.y default

tested with osmo-remsim-server and osmo-remsim-bankd on amd64


Checklist

  • making sure /etc/osmocom is there and atleast a stub bankd_pcsc_slots.csv
  • change the default ip for the server-ip in bankd defaults to 127.0.0.1 instead of a 10.9.x.y default
  • get it into latest (new release / backport?)

Associated revisions

Revision debcd86e (diff)
Added by osmith 4 months ago

etc_default: change bankd, client ip to 127.0.0.1

Related: OS#5187
Change-Id: I8dffe950b0f041a231708521d11b027bfbd304e3

History

#1 Updated by osmith 4 months ago

  • Checklist item making sure /etc/osmocom is there and atleast a stub bankd_pcsc_slots.csv added
  • Checklist item change the default ip for the server-ip in bankd defaults to 127.0.0.1 instead of a 10.9.x.y default added
  • Checklist item get it into latest (new release / backport?) added
  • Status changed from New to In Progress
  • Assignee set to roh
  • % Done changed from 0 to 70

Patches: https://gerrit.osmocom.org/q/topic:remsim-install-examples

To get it into latest, either a new release needs to be made or these patches + the ones adding systemd service files need to be backported.

roh, assigning to you, what makes more sense?

#2 Updated by roh about 2 months ago

  • Assignee changed from roh to osmith

i think a new release would be nice.

#3 Updated by laforge about 1 month ago

roh wrote:

i think a new release would be nice.

updated osmo-remsim depends on updated simtrace2, depends on updated libosmocore. So we will have to tag releases for at least those to facilitate that. I've asked on IRC if anyone knows reasons for not tagging a new libosmocore release at the moment.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)