Project

General

Profile

Actions

Bug #5571

open

DUG can come up, but with Avail: "Power Off"

Added by keith about 1 month ago. Updated 19 days ago.

Status:
New
Priority:
High
Assignee:
Target version:
-
Start date:
05/24/2022
Due date:
% Done:

0%

Spec Reference:

Description

Sometimes, after starting osmo-bsc, The BTS will transmit, we even start to get Channel requests, but this is the status:

OsmoBSC# show trx                                                                                                                                                                     
TRX 0 of BTS 0 is on ARFCN 251
  RF Nominal Power: 37 dBm, reduced by 0 dB, resulting BS power: 37 dBm
  Radio Carrier NM State: Oper 'NULL', Admin 'Unlocked', Avail 'Power off'
  RSL State: connected
  Baseband Transceiver NM State: Oper 'NULL', Admin 'Locked', Avail 'Power off'
  E1 Signalling Link:
    E1 Line 0, Type e1d: Timeslot 1, Mode RSL
    E1 TEI 0, SAPI 0

and of course we get such as this:

DRSL NOTICE <0003> abis_rsl.c:2193 (bts=0) CHAN RQD[Location updating]: no resources for SDCCH 0x4, retrying with TCH_F
DRLL DEBUG <0000> lchan_select.c:299 (bts=0) lchan_select_by_type(TCH_F)
DRLL DEBUG <0000> lchan_select.c:233 (bts=0) lchan_avail_by_type(TCH_F)
DRLL DEBUG <0000> lchan_select.c:65 looking for lchan TCH/F: (bts=0,trx=0) trx not usable
DRLL DEBUG <0000> lchan_select.c:65 looking for lchan TCH/F_PDCH as TCH/F without pchan switch: (bts=0,trx=0) trx not usable
DRLL DEBUG <0000> lchan_select.c:65 looking for lchan TCH/F_PDCH as TCH/F: (bts=0,trx=0) trx not usable
DRLL DEBUG <0000> lchan_select.c:65 looking for lchan TCH/F_TCH/H_SDCCH8_PDCH as TCH/F without pchan switch: (bts=0,trx=0) trx not usable
DRLL DEBUG <0000> lchan_select.c:65 looking for lchan TCH/F_TCH/H_SDCCH8_PDCH as TCH/F: (bts=0,trx=0) trx not usable
DRLL NOTICE <0000> lchan_select.c:305 (bts=0) Failed to select TCH_F channel

Stopping and restarting osmo-bsc will sooner ( or later :-/ ) get the TRX up....

Attached is osmo-bsc.log of the bring-up and pcap of same.

I suspect there is something happening in a certain order sometimes that causes this?


Files

abis.pcap abis.pcap 23.6 KB keith, 05/24/2022 01:48 AM
noAvail.log noAvail.log 172 KB keith, 05/24/2022 01:48 AM
Actions #1

Updated by keith about 1 month ago

  • Description updated (diff)
Actions #2

Updated by laforge 21 days ago

  • Assignee set to laforge

Plan to look at it after June 15

Actions #3

Updated by tnt 21 days ago

By any chance is the TRX well cooled ?

Actions #4

Updated by keith 19 days ago

tnt wrote in #note-3:

By any chance is the TRX well cooled ?

In at least one case where this is observed, the TRX (RUS 01) is mounted in an RBS 6601 - (with rear fans running at full speed as there's nothing to connect to the EC)

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)